I just uninstalled and reinstalled Hangouts to get the updated version. (Even though the market showed the new version, it didn't have "Update" yet).

Now, I cannot log in to Hangouts... it keeps asking me to add a Google account. I've tried rebooting the phone, but no joy.

Gmail and other google apps still work fine, it's just Hangouts. I've tried adding my account, and it tells me that it already exists on the device (which is true).

  • Have you tried to associate the app (Hangouts) with the google account on your phone? Check your setting from within the app. – RainyTaxi Oct 17 '13 at 5:29
  • I cannot get into the app. As soon as I click on the icon, it pops up with the "Add a Google Account" form, and just gives me the options of [Existing] or [New] – eidylon Oct 17 '13 at 5:31
  • You should probably try adding your existing account from that option. Or Try checking Settings > Accounts & Sync > (Your Google account) – RainyTaxi Oct 17 '13 at 5:36
  • As stated above, I have tried adding my account, but it then tells me that the account already exists on the device, which it does. And under the sync settings, I do not see an option for Hangouts. :/ – eidylon Oct 17 '13 at 5:43
  • Okay... I figured it out. I am running the XPrivacy Xposed module, and when I reinstalled Hangouts, XPrivacy defaulted it apparently to not have access to the accounts on the device. I cleared the XPrivacy settings for it, now all is good! :) – eidylon Oct 17 '13 at 5:45

So this turned out to be a pretty easy fix, once it dawned on me what it was. I just recently installed the Xposed framework, and the XPrivacy module. When I uninstalled the old Hangouts, it must have deleted all the old permission settings in XPrivacy, and then when I reinstalled it, it defaulted to maximum restriction.

With access to the phone accounts restricted, Hangouts was not able to see my google accounts.

The fix was as simple as fixing the permission settings for Hangouts in the XPrivacy module.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.