1

Whenever I run Root Debug FS for my Samsung Galaxy Stellar (4.1.2 jb, Model # SCH-I200, baseband I200VRBME1), I get this error:

enter image description here

ADB.exe is an application in the same folder as the batch file, but it says it won't run. When I run ADB.exe it just flashes the commnad line and goes away after writing out a ton of text (it dissapears too quickly for me to read it)

2
  • 1
    Running adb without parameters causes it just to show its "help page". Please try the following: Open a command shell, change to the directory adb.exe and your batch file are in, and try running the batch file from there. My guess is that directory is not in your %PATH%, and thus the batch cannot find adb.exe when executed "from elsewhere".
    – Izzy
    Oct 19, 2013 at 21:03
  • Glad to read! I made it a full answer for you to accept then, listing up the other possibilities along. Enjoy!
    – Izzy
    Oct 20, 2013 at 0:18

1 Answer 1

1

As it turned out: with adb.exe not being in the %PATH% (or $PATH for Linux/Mac users), the batch file was not able to find it. So there are 3 solutions to it:

  1. fixing the batch file to look in the very same directory
  2. fixing the %PATH%/$PATH to include the directory
  3. changing into the directory the batch (and ADB) files are located in, and running it from there

For a one-time run, #3 is the easiest approach:

  • open a command shell (on Windows via the start menu, open a cmd – on Linux via ALT+F2 and entering e.g. xterm)
  • change to the directory (using the cd command with the directory as argument; on Windows, you might need to switch to the correct drive letter before)
  • run the batch/shell script from there

If you need that script more often, it might be worth trying one of the other two approaches. Not being a Windows user, I don't know where exactly to add the PATH information there (AFAIR it was in "Environment variables" somewhere in the settings of the control center); on Linux you can just do so in your $HOME/.profile or $HOME/.bashrc, adding a line like

export PATH=$PATH:/where/is/adb

(of course using the correct path instead of /where/is/adb).

Fixing the script/batch is a little beyond the scope of our site :)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .