4

Using for the first time latest Chrome (v30.x) on Android 4.0.4 ICS on a 1st Gen. Samsung Galaxy Tab 10.1 tablet. To my huge surprise am not able to upload any files other than images or camera videos? In any webmail when I click attach a list of apps is displayed that includes Gallery, Camera etc. But the in-built file manager (My Files) is nowhere to be seen. Thinking there was a problem with it I tried many other file manager apps but none of them show up either. In stock Android browser though the in-built file manager is visible and allows me to select and upload files with any extension.

What could be wrong with Chrome and if possible how can I fix it?

2
+50

As confirmed by OP this app resolved the problem App Picker Classic. From app description

If you have app choices that are currently hidden - maybe you chose "Always" by accident once, but you'd like to be able to reinstate the app and choose each time - then reset these by clearing the defaults in the application manager of your phone/tablet.

Once you clear the defaults in app settings, and try to upload this app would appear in the choices (in addition to 4 options: Camera, Camcorder, Sound Recorder and Gallery). Using this app you can select the file explorer app on your device to select the file you wish to upload

In addition, this app permits working with some app intents and resolves common URLs.



Note: Solution below did not work for OP but I am retaining it since it worked for me, and may help someone else too

It is possible by Local Storage App which doesn't offer a UI (though it does have) but integrates with Android system to pick all files from within the device and on external SD.

Tested on Samsung Note 2 running custom ROM 4.4.2 using Chrome 53.0.2785.124 in desktop mode ( latest on Play Store)

Local Storage uses the new Storage Access Framework to allow other applications to read or write any file in your primary storage and read from secondary external storage devices (such as SD cards). On Android 5.0+ devices, you can also select entire directories and rename files.

Documentation on App Github says it is compatible with API 19 upwards

Example

Uploading a .pdf to PDF to doc site . Steps are shown sequentially in the panel of screen shots

  • Click upload

  • Choose documents option

  • From the selection panel offered by the App choose the upload file location ( external SD in my case)

  • Selected pdf file being uploaded

  • pdf file uploaded and converted to doc

enter image description here enter image description here enter image description here enter image description here enter image description here

  • I've installed the 'Local Storage' app but I can't find the 'Documents' option in the 'Choose an action' popup as in your second screenshot :-( Also, I can't find my microSD card (Inserted, other apps can find it) in the app when I manually open it and press the 'OPEN ALL FILES' button. – Spikatrix Oct 21 '16 at 16:05
  • Thanks a lot! The 'App Picker Classic' app from your other answer worked! I'll be glad to award you the bounty once you mention that app in this answer. – Spikatrix Oct 22 '16 at 5:31
  • Unrelated, but how do I check the API level of my device? Does the settings have it? – Spikatrix Oct 22 '16 at 6:15
  • Only the OP can accept your answer. I'm not the OP. Charles is. – Spikatrix Oct 22 '16 at 6:17
  • Oh ok..I didn't know that. To answer your API query , see what is API, API corresponds to the version you would find in the settings – beeshyams Oct 22 '16 at 6:20
-1

Install AndroidZip or ES File Explorer and you'll be able to upload files from any browser.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.