I'm trying to get my phone (JiaYu G3T) working under adb on Windows 8 x64 (worked fine on Windows 7 x64 before reinstalling my OS).

Driver Android Composite ADB Interface, version, works fine.

My adb won't list any devices (adb.exe devices).

I tried:

  • installed Google USB driver
  • enabled debugging mode in phone
  • added my device's hardware IDs to the Google USB driver inf file and installed
  • installed Moborobo (phone works fine in there but adb still won't find the device)
  • tried switch Settings > Storage > Menu > USB Computer connection to "Camera (PTP)"
  • tried two different version of adb (1.0.31 and 1.0.26)

Those were some of the advices I found so far.

  • 1
    Maybe you try Koush's Universal ADB driver. In many similar cases, this brought the relief. Unfortunately not in all, but in many at least – so worth a try.
    – Izzy
    Oct 24, 2013 at 7:25
  • Sadly, that didn't help, thank you for your help though! It claims that the driver is already installed
    – Kraken
    Oct 24, 2013 at 7:36
  • You might have to uninstall the other one first.
    – Izzy
    Oct 24, 2013 at 9:03
  • I did and the driver works fine but still no device :/
    – Kraken
    Oct 24, 2013 at 10:28
  • Sorry, then I'm out of ideas. I don't use Windows.
    – Izzy
    Oct 24, 2013 at 10:35

5 Answers 5


The drivers that come with PdaNet may work. Give it a shot


Finally it works, I'm using the Google USB driver. The problem is that I have to keep killing adb.exe before doing anything really (e.g. building and pushing an apk to the phone), otherwise it can't find the device.


Try installing the Microsoft User-Mode Driver Framework (http://support.microsoft.com/kb/2685813). It will require a restart.

Worked for me, Nexus 5, Windows 7 SP1.

I tried the Google USB Driver (http://developer.android.com/sdk/win-usb.html) but it didn't fix the issue for me. The Microsoft User-Mode Driver Framework, however, did.


While I was able to adb push from within android OS, I wasn't in recovery mode.

Turns out the culprit was Cyanogen Bootloader. Once I flashed to TWRP, I could use ADB again from recovery mode.


I had a similar issue (with a Nexus S, but I don't think it matters here). I could manually install the Google driver and it started without reporting problems. Nevertheless, adb devices did not list any device. Two things looked suspicious (and are probably related), but I could not use them to get a clue to the solution:

  • The hardware ID reported in device manager did not containe the part "&MI_01".
  • The driver installer warned me that the driver would not match.

Finally (and just by fluke) I found the solution that worked for me: somehow my Windows 7 installation had lost the files usb.inf and usb.pnf from C:\Windows\inf. I followed the advice in https://superuser.com/a/515823/341332 to repair the issue (basically: find the missing files in c:\windows\system32\driverstore\filerepository and copy them back), then I uninstalled my Nexus S in device manager and reinstalled it. I had to select the Google driver manually again, but this time: no warnings, the hardware ID ends with "&MI_01", and most important: adb devices now lists my device :-)

I hope this helps others that get stuck like me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .