0

I'm having some strange problem with my Sony Xperia SL. I use Virtual Router Manager on my Laptop to connect my mobile to internet over Wi-Fi. Since this morning, none of the apps are connecting to Internet (Play Store, Instagram, Subway Surfers, Browsers, etc.) except WhatsApp.

I've tried resetting Settings on my phone. Also reset the Wi-Fi modem on my Laptop, but still the same. Any solution?

migrated from stackoverflow.com Oct 24 '13 at 12:14

This question came from our site for professional and enthusiast programmers.

  • What about other wireless networks? What about mobile networks? Is your device rooted? – potAito Oct 24 '13 at 11:35
  • No the device is not rooted. I just can't understand how only whatsapp is working and not other app. Not even opening websites in browser. – Nikhil Phirke Oct 24 '13 at 12:45
  • what about mobile networks? – maxpesa Oct 25 '13 at 22:00
1

Try cleaning cache, e.g. using the All in One Toolbox, then restart your phone.

1

It's a DNS problem. Try using Google's DNS (8.8.8.8 and 8.8.4.4). Some routers let you change DNS settings.

  • What made you think it is a DNS server problem? Please back your claim with credible sources. – Manubhargav Oct 8 '15 at 1:43
0

It might be a wrong configuration on Windows Firewall.

  1. Open your Windows Firewall in the control panel
  2. Check if the firewall is on for Work or Private networks
  3. If it is, then turn it off for this firewall

Now you should be able to connect to the internet again.

  • 2
    If its a firewall issue then why Whatsapp is working? – Firelord Apr 30 '15 at 17:05
0

You may have an incorrect DNS configuration. Check "Obtain a DNS automatically" or use a public DNS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.