On an Android device (Galaxy Note 2) with a locked screen whenever an SMS is received it's preview is displayed over the locked screen. This is super inconvenient - anyone who is nearby can see it without even unlocking the screen.Is there a way to disable those previews over a locked screen?

  • Messaging Apps like Viber has settings to enable or disable these features. You can check how to setup those settings here justcode.me/how-to/… – Luzan Baral Sep 6 '17 at 16:26

i have been annoyed by this as well!!

even after turning off as mentioned above i was still receiving the notification and preview of the msg

my problem turned out to be an add on sms widget for evernote "sms to evernote" that gives you the option to send your sms to evernote.

It is not obvious from the pop up that it is evernote

there are two options in the "sms to evernote" settings

"Enable sms pop up" when you enable this you get further options to "hide sms in pop up"

The "hide sms in pop up" option does not work you get the preview regardless

it took me a while to work this out and i hope this saves someone else some time :-)

  • You might want to format the question to be more on-point, I almost deleted it as a "Me Too!" answer. – onik Feb 10 '14 at 10:57

Open the SMS app and fire up the Settings option from the Menu button.

In the Notification Settings sub-section there is a Preview Message option. If checked, that will show a preview of the message in the status bar and on the lock screen.

Uncheck it, and your problem should be solved.

Yes, you can do that using Settings->Lock screen settings and changing there widgets.

You can go to Messaging, go to Settings by pressing the button next to home button, scroll down and disable Preview Messages ... or even better disable notification.

protected by Community Sep 22 '14 at 4:18

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.