2

I am unable to play YouTube videos from the links I get on my Facebook Messenger app.

Here's what happens:

  1. A friend of mine posts a video link to me (YouTube link) as a message on Facebook.
  2. I receive it on my Android mobile in the Facebook Messenger app.
  3. I click on it and it shows a dialog box (you can call that a pop-up) which asks me to choose an app to open the video with.

Now earlier, there used to be video player apps on my mobile along with the internet browsers installed on my mobile that used to come up there. So I would select an internet browser, and it, in turn, would re-direct me to the YouTube app itself.

However, now, I am only getting video players in that dialog box as an option to open the YouTube video, but of course, if I select them, they are not able to stream the video.

Has anyone found a way around this problem? It is really bothersome.

5
  • I don't quite understand what you mean by "I am only getting video-players in that Dialogue Box as an option to open the YouTube video". Do you mean the YouTube app and web browsers don't show up in the chooser, but some other video players do?
    – Dan Hulme
    Oct 26, 2013 at 17:57
  • Yes, exactly ! Not some, all video players except YouTube and internet browsers show up ( I have MX Player and Samsung's default video player installed on my phone) Oct 29, 2013 at 9:53
  • If it's not too sensitive, could you post a link that does this? I'd only expect other players to show up for a direct link to a video file, and I'd always expect YouTube to show up for a youtube.com/watch link.
    – Dan Hulme
    Oct 29, 2013 at 10:30
  • All youtube links behave this without exception when sent through the Facebook Messenger app Oct 30, 2013 at 16:18
  • 1
    @DanHulme, Here's a link which causes this problem. It's a standard YT link: youtube.com/watch?v=Jk9TW5U1_So
    – Gaia
    Nov 5, 2013 at 2:12

2 Answers 2

0
  1. Go to the Settings on Facebook Messenger app on Android
  2. Navigate to "Photos and Media"
  3. Activate/turn on "Open links in default browser"
1
  • Have you tried this? Does it work? Oct 13, 2022 at 1:16
-3

Try going on to app settings and turn on "links open externally" fixed it for me.

2
  • Are you sure this works for Messenger? I don't see the option on Messenger itself, only on the main Facebook app.
    – Andrew T.
    Jun 26, 2015 at 1:44
  • 1
    That setting exists only in the Facebook app, not Messenger. It also has nothing to do with this type of behavior.
    – TurboFool
    Jun 29, 2015 at 23:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .