My Galaxy GT-S5360 is not being detected via USB when I connect it to my PC. It still charges however. It used to work and there was a prompt to connect it to the computer but now it just charges directly. I have downloaded Samsung Kies but it still won't connect.


A USB connector has two pins for 5V and two for the data signal. Seems like the first are still connected while the latter are not.

  • Have you tried another cable and restarted your PC?
  • It's also possible that the phone's socket is damaged or has connectiviy problems.
    It's soldered onto the phone's logic board. Did you once drop it with the cable inserted?
  • 1
    Third option may be some settings on what the device is supposed to do when USB gets connected. On some devices, this can be set to "charge only". Maybe that setting was somehow switched accidentally?
    – Izzy
    Oct 27 '13 at 8:35
  • 1
    fourth checking for how the device is observed by the PC OS in the OS device manager. "unknown device" (uninstall to try again) Known device see if it has a flag /!\ on it , what the drivers were that may or may not be needed. In windows device manager you can observe the arrival of a device as it goes from "hidden" (ghosted) to active, trying to see what the OS thinks it sees .
    – Psycogeek
    Feb 21 '14 at 4:29
  • @Izzy then how to reverse it back Jul 20 '16 at 12:54
  • @KasunSiyambalapitiya usually there's a notification like "connected via USB (tap to …)". Tap it. If not: Settings › Storage, tap the "overflow menu", check the USB connection mode. Side-note: "charge only" is the default with Android 6+ – where it might even revert back to on reboot.
    – Izzy
    Jul 20 '16 at 13:34
  • Changing the cable solved my problem
    – Eido95
    May 19 '17 at 20:04

I have just experienced same kind of problem for my Samsung Galaxy S3-SGH i747. I overcome this issue by:

  1. Go to dial pad & type *#0808#
  2. It displays USB settings
  3. Select MTP+ADB option
  4. Press OK button
  5. Connect to USB cable to PC
  6. It shows Connected as a media device.
  • 2
    After dialing the number, I get "Connection problem or invalid MMI code." :(
    – Ben
    May 11 '16 at 13:46

Please check your phone while connecting the screen should be unlock then only all your Internal and Card memory will be visible.


Check out this link at Microsoft - It seems to be a problem with Windows 8.1. USB Plug-and-Play: Plug in your Galaxy Y and then unplug/plug a different device on your PC where the Plug-and-Play works - this will cause the Galaxy Y to be detected.

Not the answer you're looking for? Browse other questions tagged or ask your own question.