I have a rooted Galaxy Tab 2 7.0 (p3113) that has worked fine for over a year. After draining the battery completely out (which I have done many times before), I plugged it in to find it stuck in a boot loop. When I plug it in over USB or a normal outlet, it shows a battery with a frozen spinning dial in the center. It then shows the same battery icon that starts animating and filling itself for about a quarter second, before shutting down and doing the same thing all over again. I can't boot in to recovery or download mode (It doesn't get to that boot stage before shutting down), and the only way to stop the loop is to unplug it. It almost seems like the act of showing the charging icon is depleting the small store of battery and making it turn off. It is not on long enough to be recognized by my computer and so I can't do anything with that (no adb or fastboot).

Is there anything else that I can do to get it to boot to recovery or stop booting on charge altogether? Or is it now just useful as a paperweight?

3 Answers 3


After leaving it in the loop for days using 4 different wall adapters and a USB port, I found the wall-to-USB adapter that originally came with my device. I plugged my tablet in with that and it booted normally and started working; I don't know why that fixed it, but it did.


Open it, unplug everything, leave for 10 mins, plug everything back in, and plug in the charger. Should work again. This is tested.

  • I don't see what this adds to the accepted answer.
    – Chenmunka
    Commented Dec 18, 2022 at 15:59

I had the intuition that the screen was discharging the tab, so, I tried disconnecting the ports that were draining the battery and charging till it could hold the initial charging phase.

I tried with different ports but, it seems to me, that one did the job.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .