1

When I try to install any of the roms of that page: http://get.cm/?device=urushi I always get this error:

Finding update package... Opening update package... Installing update... assert failed: getprop("ro.product.device") == "ST18i"|| getprop("ro.build.product") == "ST18i"|| getprop("ro.product.device") == "ST18a"|| getprop("ro.build.product") == "ST18a"|| getprop("ro.product.device") == "urushi" || getprop("ro.build.product") == "urushi" E:Error in /sdcard/cm-9.1.0-urushi.zip
(Status 7) Installation aborted.

This sounds to me, that the prop doesen't get the right string "ST18i" which is strange, cause that's exactly my model.

Do I have to downgrade or install something else first?

I also tried to install the old image Xperia Ray (ST18i)_4.0.2.A.0.42_CE.zip again, but there is just sais "installation aborted".

Are there different Rescue Menues? I read, someone tried reinstalled his rescue menu with Odin.

I installed my Recovery Mod with the app x-Parts from Google Play that app installs the CWM.

1
  • Using a program like 7-zip, you can open the script in the META-INF folder and remove that if or assert conditional which is preventing you from installing this script, or, on the actual device itself, even modify your /system/build.prop so that it reflects the requirements of the script.
    – galexite
    Jul 30, 2015 at 18:22

1 Answer 1

1

You have to install the boot image that is included in the Cyanogenmod ZIP file an flash that in fastboot:

Connect your device with Vol-Up While plugging in the USB-Cable

fastboot devices

Seeing your serial number means we know all is good.

Now type these commands:

fastboot erase system -w
fastboot erase boot

then copy the boot.img in the same folder as fastboot.exe and type

fastboot flash boot boot.img
fastboot reboot

Now press the Vol-Down Button to enter the Recovery Mode again and install your image

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .