7

I'm experiencing this issue since a month or so. I was using the camera and I received a message of some memory error, but was able to continue taking pictures. Then I realized that the pictures were not showing up in the gallery.

I connected the device to my PC and the files are actually there. In addition, I am able to continue taking pictures and access the files when using the camera (I touch the recent photos icon and I can see them).

I have tried many things, such as removing the DCIM folder, erasing the .nomedia files, erasing data from the internal memory, and none of them seemed to work. Could anyone help me?

Thanks,

Agustin

  • Have you tried triggering the Media Scanner manually? There are many apps in the playstore helping you doing so, e.g. SDRescan, Rescan SD, or Media Library Repair Scanner. – Izzy Oct 29 '13 at 7:45
  • i am facing same issue, but i am using gallery app for temporary. did you find any solution for this ? – Hitesh May 3 '16 at 16:54
6

Consider any of the solution mentioned below.

Solution 1

Note: Follow the steps for both Internal and external SD Card

  1. Go to File manager -> Android -> Data -> com.android.gallery3d.
  2. Delete the folder (com.android.gallery3d) in both internal and external SD card.
  3. Go to Settings -> Apps / Application manager -> search for Gallery -> open Gallery and tap on Clear Data .
  4. Switch off your phone and wait for few minutes (say 2-3 min) and then switch on and wait for few minutes.

That's it now. All the images and videos would be showing under Gallery.

Solution 2

  1. Go to the respective folders where images/videos are stored.
  2. Go to Settings > Show hidden file and see if there is a .NOMEDIA file. If there is such file then delete it.
  3. Switch off and switch on the device.

That's it.

Solution 3

If above solutions don't work, then you have to search for apps in Play Store which scans SD Card . SDrescan is good. It's only of 20KB in size. And then scan the memory card using that app.

0

The solution to your problem requires two steps:

  1. You have to delete .nomedia file by connecting your phone to a computer. Once you are done with that, come back to your phone.

  2. Go to storage in the Settings and do 'UnMount SD Card'. Wait for few seconds and do 'Mount SD Card', and that's it.

All your photos and videos will now be listed in the Gallery and respective apps.

-2

I have a best and easy solution for the above problem that first go to file manager > settings> show hidden files> than rename the folder .nomedia to .adc then restart your phone and remove the sd card card directly without unmount if then re insert it to the phone during switch on and watch by default it scan sd card and show media in gallery and music checkout this and if it doesnot work than delete the folder .nomedia and do the step of remove and insert sd card again then open gallery ok

  • 1
    1) .nomedia usually is a file, not a folder 2) OP already stated those files removed 3) removing the card without unmount from a running system is strongly discouraged, as it might lead to data loss. – Izzy Jan 18 '14 at 13:24

protected by Community Apr 9 '15 at 20:48

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.