0

I've been struggling with this for over a day now.

I unlocked and rooted my phone just fine (HTC One on Sprint, 4.3) - but when I flashed a ROM, I flashed Maximus HD, which was apparently an International version and not a Sprint one. I think that messed some things up. After trying a few different ROMs on top of that, nothing works.

Each ROM I flash will "install" correctly, but when it boots to the lock screen, upon unlocking it gives me the HTC splash screen.

I'm convinced that my accidental upgrade to hboot 1.55 is rendering it impossible for me to flash any working ROMs - be it stock or otherwise. I can enter Recovery mode, adb sideload, and flash ROMs, but none of them work.

I've tried Superwipe and then Bad Boyz, but it's the same thing. After installation, it sticks at the HTC splash screen.

So, my options are limited. I think I need to find a way to revert my hboot to 1.44 from 1.55 - that way at least the stock RUU is compatible. However, I can't find any way to do this; since I'm S-On, and I can't access any ROM to mess with settings, I have no idea how to do this, or how to flash a workable ROM in order to switch to S-Off.

Anyone have any ideas. I'm seriously distraught. I just bought this phone, and I love it. I'm so sad that I decided to try this rooting/unlocking/ROM flashing business because it's disrupted my sanity.

Any thoughts or ideas will help immensely. I will give more information if needed. Thanks!

0

You need to do a factory reset and wipe the Dalvik Cache. What bootloader are you using? TWRP or Clockwork would be examples. I would enter this as a comment but lack the necessary reputation.
This tread on XDA may be of use. Soft Bricked - XDA

0

I had a similar issue on mine as well. The process to fix it was not to bad, knowing that you have the issue is the key. Once you have gotten the proper RUU for your device in .zip format rename it to firmware.zip for ease of use. Place it in your folder with fastboot (sdk) boot your phone into bootloader hook up your usb cable. make sure you have the fastbootusb in bootloader screen. then type the following commands, hope it goes well.

  1. Re-lock your bootloader (fastboot oem lock)
  2. call up the RUU boot (fastboot oem rebootRUU) you should get the HTC logo at this point.
  3. flash the RUU (fastboot flash zip firmware.zip) at this point you could get an error 90 use the up arrow on keyboard to reselect your cmd command and hit enter. if no error or when complete type (fastboot reboot-bootloader)

GOOD LUCK MANY THANKS TO O.M.J. at xda for helping me with this issue when I ran across it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.