4

I want to use my phone with the google calender, but I don't want to upload all my contacts from my phone to google.

How can I achieve this?

I said in the contacts App under Settings that the App Synchronisation is off, but then I deleted some test-contacts online in Gmail and they were also deleted on my phone.

I also tried the App "Root Firewall" and forbin access to internet to the contacts app, but still, there was this sync going on.

How can I achieve this in CyanogenMod? In the standard Android 4.1 it worked fine: there was nothing synced.

Or do I need another contact app to achieve this?

  • 1
    It's not the apps. Depending on the Android (or CM) version, the location might slightly differ – but somewhere in the sync settings you can explicitly say what to sync, with separate entries for calendar, contacts, and other things. It doesn't help to block the contacts app, sync is done by the GSF (Google Services Framework). – Izzy Oct 30 '13 at 22:00
  • I cannot say not to sync there, I can only press on each one of them and say sync now. – rubo77 Oct 31 '13 at 15:39
  • Are there no checkmarks next to the entries? If not, what happens if you short-tap the sync symbol – does it switch colors (to gray and back, where gray should say "sync off")? Maybe you could add a screenshot? – Izzy Oct 31 '13 at 15:52
  • no checkmarks, no sync symbol. when I tap on calendar, a syncsymbol appears. – rubo77 Nov 1 '13 at 22:32
  • And when you tap it again, the symbol disappears (so if it's there, it could mean "activated" – if not, "deactivated")? Again, a screenshot would be helpful. – Izzy Nov 1 '13 at 22:35
3

In the syncronisation screen you have to turn Synchronisation on global. Only if that is on you have checkboxes next to each category inside the google account. you can uncheck the box at Contacts then.

If the global sync is OFF you don't have this option.

I think it is a bit dangerous the first time you enter that menu, because you have to be sure your internet connection is disconnected. Otherwise the first time, when all sync boxes are still ON it will start right away to sync everything before you have the chance to disable the sync-box for contacts.

If you are offline you can setup everything like you wish and then it's fine.

1

To make sure that none of my contacts get synychronized to google (Setup: Cyanogenmod 10 with Android 4.1) I deleted the GoogleContactsSyncadapter.apk in folder /system/app/. After restarting no contacts got synchronized, if I add a new contact I also get the information, that the contact will only be stored locally. Google Calendar synchronization works normally.

See also this thread.

  • How did you delete it? I couldn't. But I could deactivate the app in the Apps list – rubo77 Nov 4 '13 at 22:54
  • I found out: I used ES explorer and enabled Root explorer there. Then I could uninstall system apps – rubo77 Nov 4 '13 at 23:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.