2

I recently switched phones but am keeping my old phone for use on WiFi. I have put the phone in airplane mode to improve battery life and keep it from looking for the cell network (as this is futile, it is no longer activated).

However, now every morning I am getting an error telling me that Backup Assistant was unable to sync. At first I thought this was very strange as I have a WiFi and Internet connection. However when I finally went into the app to see what was going on it told me I was in airplane mode and asked did I want to exit airplane mode or cancel. Obviously I don't want to exit airplane mode so as to save battery life, nor do I want to have to manually sync as that defeats the whole purpose of automatic backup.

How can I get Backup Assistant to work without leaving airplane mode?

6
  • 1
    While there might be work-arounds available (I know of none, though), you should contact the dev of the app and report that as a bug. He checks the wrong setting: it's not important whether you're in airplane mode, but whether a network is available. And cell network definitely is not required here ;) In case there's no response, consider switching to another app (or use another app to sync your data, e.g. FolderSync).
    – Izzy
    Oct 31, 2013 at 16:05
  • I have not looked at FolderSync, but am I correct in thinking it won't interoperate with Backup Assistant on another phone on the same account? In any case, it doesn't even seem like there is a way to stop it from trying to sync (unless rooted). I'll contact the dev shortly here...
    – Michael
    Oct 31, 2013 at 17:32
  • How do you have a wifi connection in airplane mode? On every Android device I've used, airplane mode disables wifi, as well as the cell transceiver and bluetooth. Does Motorola just do airplane mode weirdly?
    – Compro01
    Oct 31, 2013 at 17:47
  • Yes, WiFi works fine in airplane mode, although it is a bit wonky because the order seems to matter - I have to enable WiFi after airplane mode. Although, upon reboot WiFi is shut off even when it was enabled before, so I just have to enable it after reboot and it works fine.
    – Michael
    Oct 31, 2013 at 18:15
  • @Compro01 I use that on many devices that way: enable airplane mode (switches WiFi off), then enable WiFi again. Works like a charm. I didn't even have Michael's problems concerning a boot, it simply restored that state (airplane on, WiFi on). Though I have to admit Tasker could have to do with that a little (re-establishing the state after a reboot I mean).
    – Izzy
    Oct 31, 2013 at 19:13

1 Answer 1

0

Definitely contact the dev about that, like Izzy suggests.

You could simply not use Airplane mode (you're not really saving battery life if you're still enabling WiFi and other radio connections like Bluetooth and GPS) and just disable mobile data on your device. This article indicates that you can easily disable Data by going to Settings > Battery & data manager > Data Delivery > and un-tick the Data enabled option. This might vary across devices and carriers.

That should allow you to use your device without a mobile carrier network connection, saving battery by not searching for the network, and allow the app to work just fine.

4
  • I have to disagree on the "not really saving" part. Airplane mode consists of switching off all antenna (BT, GSM, WiFi, NFC) and maybe even some more things. If then only WiFi is re-enabled, those other radios are kept off and thus are not eating anything. See my answer here for details, and add some overhead to the standby values for the radios looking for available connection points in intervals. Unticking data wouldn't make a difference in this case, as Michael doesn't even have a SIM inserted.
    – Izzy
    Oct 31, 2013 at 19:19
  • Fair enough, although if Airplane mode only turns off all radio communications (which is almost certainly all it does from what I've found), turning them back on defeats the purpose of using it. Most people can perpetually have NFC, BT, GPS disabled without having to resort to airplane mode. I also failed to see that he's on Verizon, so the SIM card criteria didn't even cross my mind. I'll delete my non-answer when the OP finds a real, better solution.
    – filoxo
    Oct 31, 2013 at 20:31
  • If you want to discuss this, chat might be a better place (and you have the required rep for that, so be welcome ;) But to make it short: It's easier to enter airplane mode and then enable WiFi only – than to disable GSM, BT, NFC separately and think what you might have forgotten. Next to the fact that many devices wouldn't even let you do that.
    – Izzy
    Oct 31, 2013 at 20:43
  • I contacted the dev, which in this case is actually the carrier (Verizon) but they weren't too much help.
    – Michael
    Oct 31, 2013 at 20:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .