5

I have a Chinese tablet named Quest. I have accidentally repeated the pattern lock more than 5 times. Now I have also forgotten the email address.

So for a factory reset of my tablet, I simply booted it into recovery mode. But it shows an Android bot lying with a red exclamation mark. After spending hours, I found a shortcut i.e., Vol + and Power to access the recovery menu. But my tablet doesn't go to the recovery menu even when I pressed the keys.

So I simply connected my tablet to my PC via USB and installed drivers. In adb command prompt, I typed adb devices. Now my tablet is listed as 20110301 recovery. I can simply use only adb pull, adb push, and reboot commands. But I can't access adb shell to unlock my tablet. it simply says exec '/system/bin/sh' failed: No such file or directory (2).

What can I do?

8
  • Have you checked with Cannot unlock tablet as have no internet connection? Many ways are listed up there, maybe one of them proves helpful for your situation as well.
    – Izzy
    Nov 1, 2013 at 12:38
  • Thanks for your reply!!!But it does'nt solves the problem.Because they are also telling to use adb shell to unlock the tablet.But i can't even access adb shell .What to do?.Other methods does'nt works.
    – ShihabSoft
    Nov 1, 2013 at 13:16
  • You've "forgotten the email address"? Have you ever used Google Play Store on a PC to install apps? If you're failing to factory reset then your only option (as far as I'm aware) is to use the email address. Nov 1, 2013 at 13:25
  • 1
    If you tried all methods mentioned there, I'm out of ideas, sorry. Except of trying fastboot mode and use fastboot -w to wipe all userdata and cache (which basically is the same as a factory-reset).
    – Izzy
    Nov 1, 2013 at 13:26
  • My tablet doesnt support fastboot mode.when i started into recovery mode it shows only android bot lying down with red traiangle and cant get recovery menu even after pressed power then press volume up.What to do ?Is there anyone in the universe to help me.Anyway Thanks!!!
    – ShihabSoft
    Nov 1, 2013 at 18:55

4 Answers 4

4

You have a stock recovery. Try to boot to fastboot, using ADB: Apply this command in ADB while in recovery:

adb reboot-bootloader

or:

adb reboot bootloader

Try each one, if the first works, good. Check if the device is visible by:

fastboot devices

If it outputs nothing, try the other command. It should work now.

Now you have to flash the recovery using fastboot flashing abilities. After that, try again.

1
  • I'm in the same situation and I tried to put the device into fastboot without success. Do you have any other ideas?
    – Vincent
    Jun 4, 2014 at 2:17
3

On stock recoveries, the ADB utility only registers that the device is connected when you invoke the sideload utility which gives an error when you try applying adb shell or any other thing. It only accepts push commands to the device. ADB also works when your phone is on, which is a problem when you have boot issues and can only get to recovery.

Best case scenario with prerequisites: flash custom recovery via Odin.

The stock will prevent certain commands; TWRP or CWM is the industry's (root) finest and gives a provision to initialise the sideload utility or even better yet, backup to an external SD Card.

Press Home + Power + Volume Up to get to recovery.

Voila, your adb commands will work as required, not to mention factory resets and wipes.

1

If you wipe the user data. That's a factory reset.

fastboot -w

You can boot a custom recovery and also root it from there. Just fastboot boot recoveryname.img, and flash the root package, su, and superuser.apk.

If it doesn't work, it's safe because it didn't flash, just booted it. Because it will let you boot a recovery.IMG on the phone and not flash anything. Try that.

1

I have the same problem with the E-Tech ET-7008B tablet, the USB debugging is off before they made too many pattern mistakes.

My advice is to make sure the USB debugging option is checked/turned on before making any security password on your devices, but it would be easier to unlock those stolen or lost devices.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .