2

I am trying to connect things to my S4 with a USB OTG cable. Standard devices such as mass storage, keyboard and mouse all work fine. My problem seems to be with vendor class devices.

I connected an FTDI USB to UART bridge (TTL-232R-3V3) to a USB OTG cable and installed the FTDI app. I plugged in the OTG cable and the phone reccognised the FTDI chip, launched the app, waited a few seconds and then closed the app again.

I got the message:

"Prevention Information, An application has been forced to stop for an unauthorized attempt to access system in your device". (Including the grammatical error)

I have the same problem with my Arduino Uno using the ArduinoDriod app.

I tried both devices on a friend's Huawei p6 and they both worked fine. From what I can tell, this issue is specific to the S4 and seems to be related to the recent update to Samsung Knox.

Does anyone know of a work around that doesn't involve rooting the device?

I am still in the 14 day trial period of the phone, so I could swap it for a different one. How do I tell if the Galaxy Note 3 or the LG G2 will have the same problem?

migrated from stackoverflow.com Nov 1 '13 at 16:08

This question came from our site for professional and enthusiast programmers.

0

I did also read about this. KNOX seems to be blocking the communication to USB devices in some cases.

The Google Nexus 5 (LG) is also available now. Its pretty cheap for the features it offers. You should take a look at it before you swap you device. There is also a ROOT available for the SGS4 but it would break your warranty ofcourse:

This is where i read it

more about the root. only use the one from the xda-developers forum!

  • Welcome to this site! Please note that this section is reserved for answers only, file a separate question if you want to know what phones feature KNOX. I've edited your answer and removed that part. – ce4 Nov 1 '13 at 20:37
  • Thanks for the source re- knox causing problems with OTG. I think I'm going to take the plunge and buy a Xperia Z1. – Ubersheep1 Nov 1 '13 at 23:04
0

I had the same problem, and I did a backup on my PC using KIES and factory restored the phone. Then I reconnected the device to my PC, it found the backup made with KIES and then I restored my information from my KIES back-up on the pc back to the phone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.