7

What happens exactly: when I use my SIM's data connection, after 1-5 minutes of operation (be it while the phone is active or locked), I get a notification "Restricted Access Changed", losing all SIM services -- voice and data. And I get prompted for my PIN. This only happens when I use the SIM's data connection. Using my home router's Wi-fi never introduces this problem.

I had this out of the blue since several weeks ago. I didn't drop or hurt my phone in any way.

I tried using SIM cards of 2 of my friends on my phone. They never had problems on their phones (their Android versions are more recent than mine, just pointing that out). Again, after 1-5 mins of idle/active operation on my phone, we get presented with the same error message and PIN input dialog.

I tried these:

  • Reset to factory settings -- no apps, nothing. Only started Play Store and locked the phone. Just a minute later, boom, the same problem.
  • Removed my SD card. No change.
  • Tried putting the SIM more firmly in the slot (used some paper to make it fit tighter). No change. Though, I only tried that once and not very stubbornly. I guess I'll try that again in the meantime.
  • In my mobile network, I only have the options of "GSM / WCDMA (auto)" and "WCDMA only". Using either of both doesn't change anything.
  • Switching off 3G seems to "fix" this, which is of course no fix at all since the network gets at least 3 times slower. Not to mention I can't view any video, etc. I can't count that as a solution.

Here are few links from my google hunt:

Some thoughts:

  • I didn't manually install new applications by the time the problem started occuring.
  • As said, I didn't drop or hurt the phone in any way.
  • My data plan is having a limit of 1.5GB. I rarely go over 500MB, and the last month was no exception (I am regularly checking the used bandwidth and traffic on the phone).
  • The phone is rooted. I am periodically getting BusyBox updates -- I suspect that might be the culprit since it updates a plethora of system files. But I admit that I am no expert in rooting and/or flashing Android phones, and the last sentence might have been an extremely nooby statement. Sorry if that's the case.
  • The problem is consistent: with 3G enabled and only using internet from my SIM (again, not through Wi-fi, the problem is not present there). However, there's no fixed period. It varies between 1 and 5 minutes, even though I had 2-3 cases where it worked properly for ~15 mins. I am suspecting that the moment the phone's networking hardware/software goes over a certain load, the problem occurs.

Steps I didn't try:

  • Flash a new ROM. Thing is, THL don't have more recent ROMs than the one I got the phone with when buying it off a friend. He downloaded the latest image from THL's website and flashed it, then rooted it. We never tried using unofficial ROMs.
  • Flash only the radio software. (I don't have an idea how this could be done, though.)
  • Call my mobile provider to ask if my IMEI is blacklisted. Or if they have a malfunctioning cell in the area. (Still though, that can't explain why the problem does occur 6km away in a park as well, so I don't think a malfunctioning tower/cell is to be blamed).
  • Go to repair shop for diagnostic/repair of the internal antenna. I would like to leave that as a last resort. From what I hear, this could easily cost $100. And that phone costed me $200. If I have to do this, I might just go and buy a brand new Galaxy S4 as well. Still, I don't want to just throw it away. Obviously, even if I replace it, I'd like to be able to sell it and not burn the guy I sell it to.

I am out of ideas now. Even though I am by no means an Android expert, I have tried quite a few possible solutions without any effect so far.

Can somebody help with this, please?

  • 1
    Interesting. Have you tried inserting the sim chip into another device? It might be useful to know if these results/issues can be reproduced in such a case. – dotVezz Nov 2 '13 at 15:05
  • Yes, and I forgot to mention it in detail: when I tried friend's SIM cards in my phone, they also put my SIM in their phones. No issues with my SIM whatsoever on their phones. Everything leads to the conclusion that the phone is at fault. Either a malfunctioning antenna or a faulty software. – dimitarvp Nov 2 '13 at 18:59
  • And just to clarify, did their sim chips have issues in your phone? (Also, it might be a good idea to edit the question and add this info) – dotVezz Nov 2 '13 at 21:54
  • Yes, I tried 2 more SIM cards on my phone and in all cases the problem reappeared. Conversely, my SIM on their phones didn't present a single issue over a 30+ minutes of work (which is plenty enough time for the issue normally appear 10 times). This led me to the conclusion that it's a phone issue, not SIM issue. – dimitarvp Nov 2 '13 at 22:43
1

I had similar problem with my brand new Snopow M6 phone. And I'm sure, that this may be common to most Chinese Android phones. First, in Estonia we have 3 major mobile operators, and with SIM cards two of them my phone worked nicely, it did not work with my own SIM. Also tried almost everything, but then started check IMEI code through the operators' networks. And found out, that my operator follows the idea, that its not good enough just not to be in their blacklist, You have to be in their white list. So I gave them a call, and they manually added my phones IMEI to their white list and phone works flawlessly since then. So, if you buy a Chinese phone from the Internet, then first check Your IMEI through carrier, random internet sites might give You an answer, that phone is not blacklisted, but that might not be enough in some cases.

  • That's useful to know, but doesn't seem like it could lead to intermittent problems: it would either work perfectly with your carrier or not at all. – Dan Hulme Dec 14 '13 at 9:59
  • Well, it's some sort of clue. Once my phone is back from a local repair shop, I'll definitely check that out. Thank you. – dimitarvp Dec 14 '13 at 16:19
  • @DanHulme I admit I never tried this, actually, and now I regret it -- not because I regret selling a chinese phone, no ;) but because that might've given a conclusive answer to this problem. – dimitarvp Jun 10 '15 at 18:56
  • @DanHulme I'll accept your answer even though I still don't know if this is officially the solution in the case of the THL phones. – dimitarvp Jun 10 '15 at 19:03
  • @dimitko You're replying to the wrong person. It's not my answer: I'm the one doubting its plausibility. – Dan Hulme Jun 10 '15 at 21:23
1

Dial *#*#4636#*#* >> Phone Information >> Set preferred network type: WCDMA only if you have 3G connection, GSM Only if you have 2G Connection and CMDA if you have CDMA Connection. The problem occurs when the phone searches for WCDMA in WCDMA preferred and ends up getting something else.

  • If you're in Europe, I've found that setting it to "GSM only" resolves the problem. On my Nexus 4, I've tried setting it to "LTE/GSM/CDMA auto (PRL)" in the hopes that this also works when travelling to the US. – Paul Lammertsma May 5 '14 at 15:37
  • Nope; this appears to simply come and go on the Telfort NL network, regardless of the setting. – Paul Lammertsma May 5 '14 at 15:48
  • As stated in another comment of mine here, this is a non-solution for me. I successfully "downgraded" my mobile connection to the default 3G which was very slow. But what the hell is the point in this? Might as well just replace my phone, as I did back then (Galaxy S4). Never had any problems since. I have to conclude the problem was either in the Chinese Android modification or in their hardware. – dimitarvp Jun 10 '15 at 19:00
1

I had similar problem with my phone HTC desire 816 dual sim. the problem started when I travelled another country and inserted a sim of that country in SLOT 1 of my phone. my problem was solved when I removed sim of my country from SLOT 2. So my solution is like that, though its a dual sim phone, yet I cant put 2 sims of 2 different country at a same time.

0

Below setting fixed issue on my Moto-G Go to Settings>Wireless & Networks>More...>Mobile networks>Preferred network type>select either 2G or 3G as available

  • With respect, back when I had the THL W3, that was definitely not what I was looking for. I wanted the HSDPA (an enhanced 3G) mode which allows you to easily browse image-heavy social networks like Google+ and 9GAG. I already discovered that switching to much lower speeds "fixed" the issue but I wanted it to work on full capacity. – dimitarvp Jun 10 '15 at 18:52
0

I tried the following solution and the problem was resolved. This is not a hardware problem.

Go to Settings → More network → Mobile network → Network provider → then in the options select Automatic detect network provider.

After this the phone will go through some registration process and the problem will be solved.

protected by Community Oct 17 '15 at 17:43

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.