3

Within the last few days, my Wi-fi setting keeps switching to "off".

It does this even when the screen is on and I'm actively using the device.

I've checked the couple apps I still have that help with conserving battery and none of them seem to affect wi-fi. In any event I haven't installed any recently nor updated any settings in them.

What should I be checking? How can I fix this?

Motorola Droid, Android 2.2.1, unrooted

  • Have you tried more than one WAP or is this all happening on one? – Matt Feb 3 '11 at 22:09
  • You would probably know this, but have you checked to see if you have any rogue Tasker profiles configured? – user739 Feb 3 '11 at 22:51
1

I had this happen to me once. I think it had something to do with WiFi being turned on while flight mode was on, but I don't know why. I fixed it by:

  1. Turning off WiFi
  2. Turning on flight mode
  3. Rebooting
  4. Turning off flight mode
  5. Rebooting
  6. Turning on WiFi
| improve this answer | |
1

Well color me dumb.

I'd recently installed an app called "Autopilot". It's supposed to put the device in Airplane mode when there's no cellular signal. I work in the middle of an office building so it happens a lot. It burns through battery while it tries to establish a signal.

The settings led me to believe that it wouldn't touch wi-fi unless I turned a specific setting on. I didn't, because I didn't want to mess with that.

However, after I uninstalled the app, the behavior has stopped.

I should have checked that first.

Let that be a lesson: Just because you don't think it's that new app you installed giving you grief, it just might be after all.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.