I installed Adblock Plus on my Galaxy Tab 3 and it doesn't work. It keeps saying "Waiting for traffic on port 2020". I tried following these instructions and setting up the internet connection to use proxy local host and port 2020. My device is rooted. By the way, is there a simple website I can use to test to see if Adblock plus is working?

  • If all else fails, you could try a different ad-blocking program. I use AdAway now. It is available in the f-droid repository, which I assume is where you also got Adblock (since Google Play Store has removed all ad-blocking apps).
    – Stephen S
    Commented Nov 5, 2013 at 14:30

4 Answers 4


You're correct on needing to have your device rooted, be sure and double check whether your device is actually rooted or not, you can can do this by getting an app called "Root Checker Basic", it's free.

You also need to give adblock plus "SuperUser" rights using an app called SUPERSU. This can be obtained from the google play store for free, after installing it simply run adblock plus again, supersu will will then qss if you want to grant super user rights to the adblock app, select yes with no timeout limit as you don't want it constantly nagging you to re approve it's rights every 15 mins.


I had the same "waiting for traffic" problem when I rebooted (worked perfectly before reboot). Simple solution is to manually force close ABP via settings, open ABP and it will function properly again

  • very interesting; I didnt have the "waiting" problem, but it was just not working; I reboot and nothing changed, still ads coming thru it; but the force kill seems to be working til now! So many ppl having problem with it, and the answer is so simple; I read they have no ppl to work on it right now; may be someone could contribute a patch that would make it run smooth to us all :), thx! Commented Jun 16, 2016 at 1:10

If you are rooted, I would recommend AdAway. Adblock previously targeted the hosts file which is global. The hosts file method does not require setting any proxy settings. Adblock decided to change to the proxy based method though. AdAway uses the hosts method (and thus requires root)

Link (apk link if you scroll down): https://f-droid.org/repository/browse/?fdid=org.adaway


Make sure that Filtering is enabled. Open the Adblock Plus app, and turn ON Filtering.

Also, make sure that filters are updated. In the Adblock Plus app, update the filters by clicking on the circular double arrows.

Then, restart your phone. If it's really rooted (you might want to check with a root checker app), then you don't need to do anything else.

To verify if Adblock is working, you can install an app that has ads. In the example below, I installed the Back It app. At the left, you can see a Line add at the bottom; Adblock is disabled here. At the right, you can see there is no ad, and there is an Adblock Plus icon at the notification bar.

enter image description here

  • Fanboy's list hangs on "downloading..."
    – Celeritas
    Commented Nov 4, 2013 at 5:43
  • @Celeritas Why not try something else? I use EasyList.
    – geffchang
    Commented Nov 4, 2013 at 7:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .