1

Within the last few days my Nexus 4 has started behaving strangely. This is a completely stock Nexus 4 running the official 4.3 build. Not even bootloader unlocked.

What happens is that random apps will begin crashing, usually Google apps like Gmail, Settings, etc. If I try to report the crash, the crash reporter also crashes. I plugged the phone in to check the logcat and all of the error messages are the same:

FATAL EXCEPTION: main E/AndroidRuntime(31480):
java.lang.IllegalStateException: Could not create an EGL context.
eglCreateContext failed with error: EGL_SUCCESS
E/AndroidRuntime(31480):    at android.view.HardwareRenderer$GlRenderer.createContext(HardwareRenderer.java:1192)
E/AndroidRuntime(31480):    at android.view.HardwareRenderer$GlRenderer.initializeEgl(HardwareRenderer.java:1044)
E/AndroidRuntime(31480):    at android.view.HardwareRenderer$GlRenderer.initialize(HardwareRenderer.java:979)
E/AndroidRuntime(31480):    at android.view.ViewRootImpl.performTraversals(ViewRootImpl.java:1536)
E/AndroidRuntime(31480):    at android.view.ViewRootImpl.doTraversal(ViewRootImpl.java:1004)
E/AndroidRuntime(31480):    at android.view.ViewRootImpl$TraversalRunnable.run(ViewRootImpl.java:5481)
E/AndroidRuntime(31480):    at android.view.Choreographer$CallbackRecord.run(Choreographer.java:749)
E/AndroidRuntime(31480):    at android.view.Choreographer.doCallbacks(Choreographer.java:562)
E/AndroidRuntime(31480):    at android.view.Choreographer.doFrame(Choreographer.java:532)
E/AndroidRuntime(31480):    at android.view.Choreographer$FrameDisplayEventReceiver.run(Choreographer.java:735)
E/AndroidRuntime(31480):    at android.os.Handler.handleCallback(Handler.java:730)
E/AndroidRuntime(31480):    at android.os.Handler.dispatchMessage(Handler.java:92)
E/AndroidRuntime(31480):    at android.os.Looper.loop(Looper.java:137)
E/AndroidRuntime(31480):    at android.app.ActivityThread.main(ActivityThread.java:5103)
E/AndroidRuntime(31480):    at java.lang.reflect.Method.invokeNative(Native Method)
E/AndroidRuntime(31480):    at java.lang.reflect.Method.invoke(Method.java:525)
E/AndroidRuntime(31480):    at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:737)
E/AndroidRuntime(31480):    at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:553)
E/AndroidRuntime(31480):    at dalvik.system.NativeStart.main(Native Method)

Rebooting the phone temporarily solves the problem. Does anybody have any ideas? Thanks

  • 2
    You are not the only one, started happening to me just recently as well. – datasage Nov 6 '13 at 0:25
  • This is getting ridiculous, just missed a call because the dialer crashed right as it was coming in. Who knows if it was important or not – Nick Nov 9 '13 at 16:24
  • There is a bug filed with ASOP code.google.com/p/android/issues/detail?id=61868 and threads on some of the other android forums. – datasage Nov 11 '13 at 4:38
  • I see, as far as I know when I posted this there was nothing else on the web about it. I couldn't find anything at the very least – Nick Nov 11 '13 at 5:36
0

Try to disable "Automatic date & time" and "Automatic time zone". This solved my issue like this on Nexus 7 and could very well help you out here.

0

Thanks to datasage for pointing out the official bug report where many others are reporting the same problem.

Some users commenting there have found that if they stop using wireless charging, and instead charge the phone with a cable, the problem goes away. That might be a useful workaround for you until Google fixes the problem properly with an OTA update.

0

I solved a similar problem on a Galaxy SII with a transfer on the phone's memory of all applications stored on the micro SD card.

It's very frustrating to be forced to use the small memory of the phone when you bought a card with a lot of memory…

But I know two owners of android phones who suffers of the same issue, solved in the same way.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.