0

I own a GIONEE P2 mobile phone with MTK6572 processor and android 4.2.2. I successfully rooted the phone and it was working fine until my internet stopped one morning and upon restarting the phone, it wrote SIM1: SIM card not detected, SIM2: sim card not detected. I have tried all I could yet no avail as I can't use SIM card in the phone. I used MTK droid tool but nothing could be done, also entering engineering mode with ##4636##, the radio remained permanently turned off and couldn't turn on. I used IMEI tools to rewrite and replace the NVRAM files yet nothing happened. it has been very frustrating trying to find a solution but none found. Please anyone with any idea on how to resolve this issue should please help. WIFI and bluetooth still work fine.

Thanks in advance

  • Have you tried a) other SIMs in that device, and b) those SIMs in other devices, to rule out candidates? If b) didn't work either, the card(s) likely have given up. If a) failed, it could be the contacts, the hardware, or the system going havoc... – Izzy Nov 4 '13 at 23:14
  • I have tried other sim cards in the same phone as well as tried the sim cards in other phones and they are working fine. I have even done reset countless times after every modification like rewriting the IMEI but nothing changed. – David Nov 4 '13 at 23:20
  • Just to clarify: a) works, and b) works as well – so it's just the combination of original SIMs in original phone which does not work? That's weird, and I'm afraid in that case I'm out of ideas (except for asking your provider to send you some replacement SIM as yours "gave up"; at least here they send free replacements usually, had that about 2 times already in the last ~20 years). – Izzy Nov 4 '13 at 23:24
  • Thanks for your help. I have tried several other SIM cards. new ones and otherwise (smiles) but all to no avail. It has happened for up to two months now and since then I have been searching for solutions until I found this site tonight. Thanks anyways. more help are always welcome – David Nov 4 '13 at 23:39
  • If I understand correctly, and your device does not accept any SIM card anymore, that might be a case for service. OTOH, sometimes it's just the connectors (not enough "pressure" to make contact). I had that on a dumbphone a while back. Making the SIM a little "thicker" (put/glue something atop) solved it then. – Izzy Nov 5 '13 at 1:10

protected by Community Jun 30 '14 at 13:43

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Browse other questions tagged or ask your own question.