So this is very odd.

Last night my phone rebooted itself. Nothing unusual there - it does it from time to time. However, this morning when I try to read the news I get

"Application is not installed on your phone".

So I check some more apps and lo and behold I get the same message. Any app that was installed on my SD card has gone - but only partially. The icon still exists on the "desktop" and the system name appears on the list of installed apps on the phone, but the Google Play store doesn't think they're installed - which is different to the symptoms described in these questions:

All apps moved onto the SD card have disappeared

My apps status suddenly become "not installed on the phone", even the google play store!

which both state that the applications are still listed as installed in the Play Store.

Also - now I think about this a few apps had gone missing earlier. I have gaps in the icon field where I know there was an application, but because I didn't use it everyday I can't remember which ones :).

I've tried removing and reinserting the SD card, but that's had no effect.

When I reinstall applications that have local data and/or stored account details this information is still present. For example when I opened the Amazon MP3 player it didn't prompt me for my Amazon account details, but just showed the list of albums I've purchased. This implies that it's just the folder that hold the executables on the SD card that's been deleted/corrupted.

I've started reinstalling apps, but I'm concerned that this might happen again.

So does anyone have any ideas why this might be the case?

  • 2
    Comment since I'm very unsure of this -- there have been cases when something similar (but not the same; in my case directory listing worked but the files were all empty on the card) has happened to me; which were fixed by running good 'ol chkdsk from a Windows box. Commented Nov 6, 2013 at 9:25
  • @Manishearth I will try this when I get home tonight - I don't have a micro SD card holder/converter here at work (actually I'm not sure where the one I have at home is - but at least I know I have one!)
    – ChrisF
    Commented Nov 6, 2013 at 9:26
  • Hmm - chkdsk H: /F -> "Cannot read boot sector". However I can read the drive from within Windows
    – ChrisF
    Commented Nov 6, 2013 at 22:11
  • 1
    It was the card failing. It took another 8 months, but it finally died this weekend.
    – ChrisF
    Commented Jul 12, 2014 at 23:33

2 Answers 2


As Manishearth wrote, this might indicate trouble with the card (and very likely does). The boot you describe might have been "too abrupt", not cleanly unmounting the card and thus corrupting its file system; in which case the "good ol' chkdsk" should help (btw, Android ships with fsck for the very same task, which you could execute via a terminal app or adb shell – see Check and fix SD card errors within Android itself?).

On the other hand, it could also mean hardware trouble with the card, which even could be the reason for those reboots, reversing cause and effect: Not being able to read/write, or encountering too many "corrupt blocks", might have triggered some event (like re-mounting the card read/only). I'm not sure whether such would trigger a reboot (as stuff counted essential by the system usually doesn't reside on the sdcard), but it wouldn't be impossible. Thus trying a new card won't hurt.

PS – A little background on : As shipped with Android 2.2+, this only moves parts of the app to your card, while other parts remain on internal storage. Especially the app's data remain here (in /data), which is why after a re-installation of your apps they were already (or rather "still") available. For more details, you might wish to take a look at our app2sd tag-wiki.

  • I've just finished reinstalling all the apps and except for one case all settings and data have been remembered so if it is problem with the card it's very localised.
    – ChrisF
    Commented Nov 6, 2013 at 12:31
  • 1
    I wouldn't be sure of that, as your arguing might be based on an error: apps' data are stored in /data, which is not on the card unless you use some (root) tools like Link2SD – which by your description you do not. Normal App2SD only moves parts of the app to the card, but never the apps' data.
    – Izzy
    Commented Nov 6, 2013 at 12:35
  • Ah - that makes sense. I had assumed that moving an app to the SD card moved everything to the card.
    – ChrisF
    Commented Nov 6, 2013 at 12:37
  • Nope, that wouldn't work for several reasons. Mostly it's that the sdcard is only mounted after the boot_completed event; thus if the entire app would reside on it, your launcher wouldn't know about the apps installed there as it might finish initialization before the card is mounted (thinking of which, that would explain your issue as well under slightly different circumstances, i.e. if really the entire app had been moved). // Give my hints a try. If they prove helpful, consider accepting/upvoting the answer ;)
    – Izzy
    Commented Nov 6, 2013 at 12:45
  • When I said "everything" I meant "everything except a pointer to the app" - which is just showing my ignorance of how these things work. I will try thing things you suggest and I've already up-voted the answer ;P
    – ChrisF
    Commented Nov 6, 2013 at 12:47

For me all apps disappeared when I extracted the internal sd card which stores internal data of my e-book (the e-book is driven by android 2.1). I made it to change partition sizes to fit more apps. Actually I turned it on without that sdcard accidently and after that all apps became uninstallable but not executable.

Not partition resizing but that accident turn on caused the problem.

So that's what I did: 1. I found a dir where all installed apk's are. for me it was /pb_data/data/apps 2. Entered adb shell and entered su in that shell (yes, root is needed) 3. entered ls to list all apk's 3. Called pm install XXXXX.apk on each of those apk files.

This install mode didn't cause any conflicts (though it installs apks to the same place so has to rewrite them somehow). Also all apps data/settings was preserved, everything is ok.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .