I have a Galaxy Note 3, and Google Now has no speech.

The "Google Search" app is up to date from the Play Store. All of my volumes are set to maximum.
I have gone into Google Now settings and selected "Voice -> Speech output -> Always speak".
I have gone into "Settings->Language and input"; under "Text-to-speech options" my TTS engine is set to "Samsung text-to-speech engine" (the only option) and its language is set to "English (US)".
I have explicitly downloaded the "English (US)" language pack from the "Install voice data" menu.
I have tried rebooting and still no luck.

Is anyone else experiencing the same issue?
What else can I try?

  • What ROM are you running?
    – pzkpfw
    Commented Nov 8, 2013 at 13:15
  • Stock. Not rooted.
    – Josh
    Commented Nov 8, 2013 at 13:15
  • Well that's probably your issue. I'm running CyanogenMod on my Galaxy Nexus and mine has the speech functionality, but my friend who has an S4 with Google Now does not have it. I'm pretty sure it updates in the background, probably only to vanilla Android (which CM essentially is). If you're not attached to your stock ROM, I would recommend rooting and flashing CM.
    – pzkpfw
    Commented Nov 8, 2013 at 13:16
  • It's not really that big of a deal. I was just trying out this trick and disappointed that I didn't hear the text: phandroid.com/2013/11/08/dr-who-android-google-now-easter-egg
    – Josh
    Commented Nov 8, 2013 at 13:19
  • Never mind, I actually figured this out myself. See my self-answer below.
    – Josh
    Commented Nov 8, 2013 at 13:23

1 Answer 1


Answering my own question, this seems to just be my misunderstanding of how Google Now works.
I was typing the search and expecting a voice response.
But apparently it only responds with a voice if you ask with a voice.
If I use voice search, then a voice does indeed reply.

Leaving this question/answer here in case anyone else has the same misunderstanding.

  • 6
    I always answer my own questions if I find my own solution because of this: xkcd.com/979
    – Josh
    Commented Nov 8, 2013 at 13:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .