I installed a CGM 10.2 "snapshot" last night that was listed by the updater as a stable build. It started draining my battery immediately, so I tried to revert (using the built-in updater) back to the 10.1.3 stable build I had previously.

After installing 10.1.3, I never get past the spinning "CyanogenMod" screen. Is there a way to transfer the CGM 10.1.x files via Odin to the sd volume on the phone so I can try to boot via recovery, or is Install from SD card via recovery the best way to try and load a build that may work?

Follow-up: I have wiped my cache, the dalvik cache, factory reset my phone, and tried both 10.1.2 and 10.1.3. I can now boot, but can't get the default (and only available) keyboard to work, so I can't even enter my google account to do anything with Android on the phone. Is there a way to directly install an alternative keyboard?

2 Answers 2


After many failures, I finally figured out what was happening. Cyanogenmod's update utility told me about a new snapshot for 10.2. I was currently on 10.1. When I installed the 10.2 "stable" snapshot, I still had the 10.1 gapps on the phone. Evidently this is what caused the boot to fail. After wiping the caches and doing the "factory reset", installing the 10.2 gapps and the 10.2 CGM snapshot, I was able to get the phone to boot successfully.

I don't know why the 10.1.3 reversion failed when I still had 10.1 gapps on it.

I'll update this answer later if battery life is still an issue, but I believe I should be able to revert to 10.1/10.1 if battery still doesn't behave well in the 10.2 snapshot.

While trying the paths, I also tried the CGM 11 (4.4) beta build. Looks pretty sweet, but I couldn't get wifi to work on it, so I went back to CGM 10.2 snapshot.


If you are going to move from CyanogenMod to stock ROM, you need to do a full wipe. Otherwise, there's big chance you are going to have issues. A full wipe is necessary when moving from one ROM to another ROM (stock to custom, and vice versa).

You should be able to find stock ROM in sammobile.

  • 1
    Thanks for the answer. If I could successfully reload any version CyanogenMod I would, but it's just not completing the boot. I'm trying to minimize data destruction, of course. Nov 9, 2013 at 18:44
  • @JohnKaster Do you have the latest CWM? Check at clockworkmod.com/rommanager I had an older version, and it was causing problems. See my recent experience: android.stackexchange.com/questions/56600/…
    – geffchang
    Nov 10, 2013 at 5:45
  • I haven't checked my CWM version in a while, but I will. I didn't look at that because I was trying to revert to a CGM build I'd successfully installed before. Thanks for the suggestion. Nov 10, 2013 at 19:35
  • I updated to, but unfortunately neither CG 10.1.2 or 10.1.3 will get past the swirling Cyanogenmod logo screen. Looks like I'm going to have to wipe it :( Nov 10, 2013 at 21:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .