0

I have a Lenovo Ideapad A2107-H and I read this guide. I followed the guide step by step to upgrade my Tablet.

On step 6 I got assert failed: getprop("ro.product.device"), so I deleted this line in the related script file and tried again.

Afterwards, I tried to reboot my device. It only shows me the Lenovo logo and won't boot into Android.

How can I fix this?

  • 1
    Welcome to the site! We're excited to have you here! Usually, when flashing these ROM images, you have to follow the steps exactly. In this case, deleting that line was probably a bad idea. I'm nor familiar with Lenovo tablets, and a Google search doesn't give me much information for how to help you. Are you able to get to Recovery mode? – dotVezz Nov 11 '13 at 16:14
  • 3
    Actually, deleting that line was not a bad idea – but a very bad idea. Because it was a "safety guard", preventing you from flashing something incompatible to your device. If and how you can recover from this, people at this forum are best to answer – as who wrote it most likely knows it best. By the way: Is your device a ZTE Warp Sequent? Because that's what the ROM over there is for. Which might explain why the assert failed (wrong device). – Izzy Nov 11 '13 at 16:55
  • i know that my device is not compatible with that ROM, but i did! and now i am very very remorseful, so i can access to CWM and when i restoring my backup, it will be crash and gives error in restoring /system partition and says: format_volume: make_extf4fs failed on /dev/block/mmcblk0p6 i think that ROM has changed partitions and it cannot be mount or something like this – user1728307 Nov 11 '13 at 19:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.