I had intermittent issues before with my Google syncing not working as it should (although I've always been able to go to google.com in the browser), rebooting usually solved it. However, after upgrading from an older 10.2 version to the latest one (via CMs own update functionality), both the Wifi icon and the mobile data icon stay completely grey. As usual, I have no issues with going to Google in the browser, so I'm suspecting this is a Gapps issue or something with the ROM.

Any ideas on what I can do to troubleshoot and/or solve this? I'll go ahead and try upgrading Gapps now and let you know how it goes.

This is not a duplicate with any question asking what this greyed out icon means, I'm asking specifically why the sync functionality stopped working with the upgrade (if anyone knows), and how to fix it (if possible).

edit I just realized I might be running 10.1 gapps on a 10.2 CM build, I'll update this if upgrading gapps solved the issue.

2 Answers 2


Upgrading gapps to the correct version (I was running 10.1 gapps on a 10.2 CM build) solved the issue. I did not have to reinstall the ROM or anything like that, simply flash the new gapps over the old.


I had the same problem (on a toro, Verizon Galaxy Nexus), grey signal icons and had almost all GAPPS unable to open at all. Most would cause a force close message when the phone was idle every few minutes.

I went to CyanogenMod Wiki: GAPPS and downloaded the 10.2 GAPPS, uninstalled all that were available in the play store (from the play store) and re-installed them immediately. Once I went through and linked them all back to my Google Account and did a restart on the phone the connection icons became the familiar and comfortable cyan color.

Once I did all that and gave the phone a day to 'soak', it's running with even more buttery smoothness than ever.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .