I have a Galaxy SII, and it is stuck on the boot screen. How can I recover the files on the phone?

  • 1
    Is your phone running the stock android? Or did you flash any custom ROMs? Nov 13, 2013 at 18:29
  • 1
    Does the phone still boot to recovery mode? Try holding down the power, home and volume Up button to start the device.
    – XZS
    Nov 13, 2013 at 23:00

2 Answers 2


I had the same problem with stock Nexus 7 2012 GSM.

The relevant documentation for this is

First of all, the bootloader has to be unlocked.

fastboot oem unlock

Unlocking the bootloader deletes user data on the device (as a security precaution). If you haven't unlocked the bootloader before, you are now out of luck. Try to find if you have backups. (Contact data may be synced with your Google account, you might have Dropbox installed, G+ backups photos and so on).

Assuming unlocked bootloader, you can flash a custom recovery which will allow you to access data on the phone.

I tried ClockworkMod, but after I booted into it, adb listed my tablet as unauthorized device, similarly as this person describes. He solved the problem, I did not.

Therefore I next tried TWRP recovery.

fastboot flash recovery path_to_twrp.img

With TWRP, adb devices listed my device with recovery permissions (whatever it means) and I could copy out my data

adb pull /data .

In addition TWRP seems to enable MTP on the device. That is another possible way to get data out. I haven't experimented with it, because I did adb pull first and I got my data that way. Additionally, in my experience, MTP clients for Linux are rather flaky.

  • I had to go to adb sideload then cancel in order to get my device into recovery mode with TWRP/adb.
    – Hybris95
    Nov 8, 2016 at 12:49

You will need the Android SDK and your phone's appropriate drivers so you can use Fastboot ADB and pull the files manually. Here's how to get into Fastboot mode:

  1. Pull battery and reinsert
  2. Hold VOL DOWN, press and release PWR button (continue holding VOL DOWN)
  3. You should see a menu with the following options: Fastboot, Recovery, Clear Storage, and Simlock; select Fastboot.

Here is a fantastically detailed guide for how to recover files (post #22):


To address the custom recovery question: if the OP is running 4.2, he/she is most likely running a custom ROM and therefore a Recovery, as the latest official build from Samsung for this device was 4.1.2 (at least on the Sprint and AT&T versions).

Hope this helps!

  • This answer is not appropriate considering the question. You can't get ADB without being able to boot. He may have a custom recovery which supports ADB, but we don't know if that's the case. I don't think the Galaxy SII even supports fastboot - and aside from that, file recovery over fastboot alone isn't really feasable (as far as I know).
    – dotVezz
    Nov 13, 2013 at 20:27
  • 1
    If the phone boots to recovery mode or download mode, more possibilities emerge from there. ADB may even be possible.
    – XZS
    Nov 13, 2013 at 23:00
  • 1
    @inquisitive_ibex It would be great if you could provide documentation for both getting the SII into Fastboot mode (Is it the same as Download Mode?) and also for pulling files over fastboot. I'm having trouble finding anything regarding it.
    – dotVezz
    Nov 14, 2013 at 17:07
  • @inquisitive_ibex Please edit your answer. Unfortunately, the comment system isn't good for formatting steps =). Also, please provide links to information about pulling files over fastboot.
    – dotVezz
    Nov 14, 2013 at 17:20
  • 1
    I'm excited by your enthusiasm (and hope you keep it up! We need more answerers around here), but your answer states that fastboot is necessary, gives instructions to get into fastboot mode (admittedly, because of my prodding), but then there's a link to a solution that doesn't need fastboot. It also assumes that OP can get into Recovery Mode - we don't know if he can (Maybe say "If you can..."). Finally, simply posting a link and saying "Here's the answer" isn't the best way.
    – dotVezz
    Nov 14, 2013 at 17:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .