8

So I have the Nexus 7 (2012). When the tablet is on and USB debugging is enabled, ADB recognizes it. But when I shut it off and put it into recovery mode, then press power and volume up to sideload, Windows/ADB does not recognize it. If I navigate to usb_driver it says it can't find a driver there. I'm trying to update it to KitKat using the OTA update.

8
  • Sounds like a driver issue to me.
    – roxan
    Nov 14 '13 at 15:57
  • why does it work when the tablet is on?
    – Chaos
    Nov 14 '13 at 16:01
  • 1
    I think it uses different driver in fastboot mode normal mode and recovery mode.
    – roxan
    Nov 14 '13 at 16:02
  • well recovery mode uses the adb driver, and when its on it should also be using the adb driver. Anyways i might of fixed it, i force installed the adb interface driver to it. Now it is recognized in command prompt adb
    – Chaos
    Nov 14 '13 at 16:07
  • The device is presenting itself using different device-IDs, depending on the mode (normal/recovery/fastboot) used. I guess that's what roxan was pointing to. Being a Linux user, I'm not sure how Windows deals with this (different driver, or same driver with different parameters, or something completely different).
    – Izzy
    Nov 14 '13 at 16:18
8

The problem is that you're missing the adb recovery driver. You might consider trying Koush's universal USB driver installer -- it solved this very problem by installing the missing drivers.

1
  • Does not work for Windows 10. See my comment to original post. Apr 27 at 8:34
1

I had a similar problem with my Nexus 5. Windows 8.1 and adb recognized the device until I put it in recovery mode, then it disappeared. I finally said "let me pick from a list of device drivers" and chose the "Android Composite ADB interface." Then adb recognized it and I was able to sideload an update.

0

I just spent way too many hours trying to fix this same problem when trying to sideload onto my Nexus 6.

What finally worked for me:

  • Apply update from ADB in the recovery menu.
  • Once the phone was waiting for the files
    • I unplugged the phone from USB
    • then re-plugged it back into the computer.
  • Then it was there in the device manager and when I did a device check through adb on my console
  • I ran the adb sideload command and it is currently optimizing my apps

Hope this helps anyone having this problem on their nexus devices.

1
  • Does not work for Windows 10. See my comment to original post. Apr 27 at 8:36

Not the answer you're looking for? Browse other questions tagged or ask your own question.