2

I tried to connect my Nexus 5 to a USB on a LinuxMint (OS) PC.

At first it worked; it asked me to choose MTP or something else. Now, it's not giving me any feedback. I tried resetting - still getting nothing.

I think it's the phone, because I'm only getting a message of charging, not of being connected to the PC.

  • What OS are you using? – Mihai Dec 9 '13 at 13:48
  • LinuxMint, I think the MTP support is just sucky because a windows laptop responded as it should. – Asaf Dec 9 '13 at 16:13
  • Rephrased question so it doesn't get closed. – geffchang Dec 10 '13 at 2:38
0

Have you tried changing the connecting USB cable?

From other forums I found out that there are charging only or charing + data cables.

It could be that something happened to the data part of it so you see it charging when connected, but the phone can't be mounted because there is no data transfer. That's why I was sure the problem had to be elsewhere, phone or computer

My previous answer suggested to move the cable to another USB port which previously worked, but it suddenly stopped working again and I had to look for another solution. Wiggling it the first time must have restored the data connection for a bit..

0

I ended up using AirDroid.
This is by far the best solution to wirelessly connect an Android to a PC (you can even make accessible only inside your LAN, so it's pretty secure).

Seems that solid MTP support is not going to happen for Linux.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.