I have videos in a directory which is protected through .htaccess. I want to deliver the videos by means of the <video> tag.

Here is an example:
protected video

Use test/test to login.

Without the protection the same video plays fine:
unprotected video

I've tried it with the stock browser and also Chrome. I am on a custom 4.0.4 ROM.

Am I the only one experiencing this issue? I couldn't find anything on Android's Bug Tracker.

  • It doesn't work for me in Firefox on Ubuntu either. I get "no video with supported file format and MIME type found". I don't think this is an Android problem.
    – Dan Hulme
    Nov 17 '13 at 22:40
  • Works for me on Firefox 28 on Windows 8. On Chrome on my Phone, it seems to keep loading indefinitely... Same on stock browser (4.1.2). Nov 18 '13 at 14:49

Both worked fine for me in Google Chrome.

I am using Mac Book Pro with OS X Maverick and the latest version of Google Chrome. On firefox ( latest version) it displays an error:

No video with supported format and MIME type found.

On safari it keeps loading. See the screen shot please.enter image description here

  • Thanks for your answer, but I was talking about Android. I thought it would be clear. Firefox doesn't support .mp4 h.264 videos yet, except on Windows.
    – TheLostOne
    Nov 18 '13 at 14:17
  • Hello, No problem. I know you are taking about Android, I have just tried to check it in my computer to see if it works in there. I thought it might be a little information to help you with this. : )
    – Zeeshan
    Nov 18 '13 at 14:21

The bug has been fixed in one of the latest Chrome Beta versions.

Here is the reference: https://chromium.googlesource.com/chromium/src/+/20bd0b28f6467339e611311aaf241d7eab388578 https://codereview.chromium.org/405663002

------------------- my original answer below --------------------

The problem also persists on Android 4.3 and most probably also with later versions.

I've reported the issue on chromium's bug tracker and it has been confirmed: https://code.google.com/p/chromium/issues/detail?id=331876

There's also a bug report on the Android's bug tracker for the stock browser: https://code.google.com/p/android/issues/detail?id=43414

I hope this issue will get fixed soon.

  • This bug is still present. Actually it's present in all Android browsers except Firefox.
    – user61067
    May 20 '14 at 5:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.