5

Starting last week, my HTC One running ARHD 31.5 keeps forgetting the default launcher. Every few minutes, it will forget the setting and ask me for a launcher when I hit the home button.

So far, I haven't found a pattern yet. Here's what I've tried so far:

  • restarting the phone
  • removing the default setting via Settings > Apps and setting it fresh
  • tried different launchers to rule out the launcher deleting the settings
  • updating the ROM (seriously)

It happens both when the phone is locked, or when I keep it unlocked and basically not doing anything but keeping the screen alive. After a few minutes, the default will be gone.

Any ideas how to debug this are welcome.

  • when you say it forgets the default launcher, what other launcher are you using? – geffchang Nov 20 '13 at 9:11
  • It's forgetting Aviate. But I have also tried setting Nova Launcher or the default HTC Sense launcher as the default and it forgets them as well. – Mario Witte Nov 20 '13 at 10:13
  • I just got the tip to try looking at "adb logcat" to see if something comes up and I get this log message: Result set changed, dropping preferred activity for Intent { act=android.intent.action.MAIN cat=[android.intent.category.HOME] } type null I'm just trying to get the context of that to see if this helps find out what is happening. – Mario Witte Nov 20 '13 at 10:14
  • When it asks you to select a default launcher, do you select Always, instead of Just once? – geffchang Nov 20 '13 at 10:29
  • Yes, I select "Always". – Mario Witte Nov 20 '13 at 10:32
1

It's still unclear what is causing this to happen and I have found only one other mention of the problem so far. In the end I simply disabled the stock launcher by freezing it using Titanium Backup and also disabled all other custom launchers. Soon as only one launcher is available, the dialog goes away. More of a workaround then a solution, so if anyone has an idea how to continue debugging, then I'm open to any suggestion.

0

I'm having the same issue likewise on Nexus 4 and on Nexus 7 (2012), with Android 4.3 and persistent after updating to Android 4.4. As I don't have rooted devices, the only 'solution' I've seen was deinstalling the nova launcher. Nova launcher was the only alternative launcher I've had installed and with only the default launcher left, the dialog is gone. A pity, though, as Nova enhances the user experience considerably.

  • There was one similar report here link. One commenter tracked his issue down to the app MoboPlayer, but this didn't seem to apply to the thread starter and the other respondents. Also I don't have that app installed. So the issue is possibly related to an unknown setting which can be influenced by apps. – Thilo Dec 6 '13 at 14:55
  • Yes, I read that thread as well. Unfortunately I also didn't have that app. Good to hear that the problem showed up with the 4.4 update for you as well. – Mario Witte Dec 8 '13 at 21:30
0

Is strange, I also go the same problem. But then, I used titanium backup to move the default launcher from a system app to user app. Only after that, I am able to set other launcher as default.

0

Try the "Fix Permissions" option in the custom recovery. Also try wiping caches and Dalvik Cache. If they didn't work try disabling any cleaners, taskers, etc. Also check "Accessibility" in settings to see if there are any services that could potentially be causing the problem. I would recommend doing these sequentially (but not necessarily in any particular order), so you can isolate what was causing the problem in the first place.

0

Scan all the applications installed to see if there are any android:proprity="-1" in intent-filters. (I know com.taobao.taobao breaks)

-1

Go to Settings -> Home. If there is any non launcher app (E.g. Times Job), then remove it and select the launcher you want as default. That might solve the problem.

  • 2
    Is "Settings -> Home" available in 4.3 JB? I'm aware of Kitkat having it, and JB 4.2.1 doesn't have such entry. – Firelord Aug 6 '15 at 13:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.