My rooted karbon s5 android phone is showing "RESET FOR ENTRY QPST DOWNLOAD" message on startup, I am unable to execute this solution (quoted below) because I dont have the Karbon S5 rom, also there are many techniques posted to unbrick the device and I am confused how to proceed with it, I have Windows 8 so how to solve this problem?

A linux distribution (Ubuntu) sys_boot.img (https://docs.google.com/file/d/0BxJJ...tEMmFQZHM/edit) Follow the steps to restore the sys_boot partition:

  1. Connect your phone to a pc using the cable
  2. Install the drivers if necessary: https://dl.dropboxusercontent.com/u/...m%20Driver.rar
  3. Open your terminal
  4. Type "lsblk" (without the quotes). You should see a list, showing every connected disk and partition. Look for a partition with a size around 50M. This is the partition we need, so remember the corresponding name under the 'NAME' column. It can be "sdc", "sdd" or "sde" followed by a number.
  5. Cd to the directory you placed sys_boot.img in cd [filename]
  6. Type "sudo dd if=/dev/NAME of=sys_boot.img bs=512 Replace NAME with the name you got from lsblk, and press enter. The output should look something like this: 3959420000 bytes (3866621 KB) copied, [ time spent], [KB/s]
  7. Remove the cable from your device, do a battery pull and try to boot your device Normally, it should boot correctly. If you formatted the /system partition too, you have to get into recovery mode by holding the upper volume button while booting, until a red screen appears.

Another specific solution quoted here, which I cant implement as i dont have acronis which is a proprietary software:

  1. download the BOOTFILES AND acronis recovery image files
  2. download drivers that i attached(if u already have them.no problem)
  3. press power button and volume up button till u get "RESET FOR ENTRY QSTP DOWNLOAD".Now connect the device to pc(windows os).install drivers if asked.
  4. open acronis true image and select backup.now all the partitions are shown in which are in ur system.uncheck all ur system related partitions and select all the partitions of the device which are shown and finish the backup(this step is for safety.u can skip this if u r confident on urself)
  5. now again open acronis true image and select recover.now select the "Partition3sector_full_b1_s1_v1.tib" file that i attached.it will ask where to recover.
  6. this is the important step and do it carefully..now u have to select the partition which is of type FAT16 and has exactly 50 mb space. now open advanced settings and select recover sector-by-sector and now click recover
  7. it will take around 4-5 mins and ask to reboot ur system showing like it is compulsory to restart to complete the process. (NOW WE AGAIN BRICKED OUR BRICKED DEVICE .DONT PANIC..CONTINUE..)
  8. so click restart.disconnect ur mobile and take out battery.dont insert it.and now u open linux os
  9. after opening linux.first keep the battery and on ur device by pressing power and volume down (carefull here.power+volume down) dont press colume up.
  10. u mobile show a message "ENTRY FOR QPST DOWNLOAD".Now connect ur mobile to the system.in linux u get all the partitions which are shown in my computer.
  11. now open the drive which id of 50 mb or around 50 mb..if u open it u can see a folder named image..
  12. open the folder named "image".u can find two files named "AMSS,AMSSHD".select these two files and delete.now extract the files from BOOTFILES that i sent which exactly contains the files names as "AMSS,AMSSHD".. COPY THESE FILES TO THE SAME PLACE WHERE U DELETED.
  13. after the copy is finished disconnect ur mobile.remove the battery
  14. reinsert the battery and now select power and volume up buttons.ha ha.now u can see the green display of recovery.from here i think u pupil know how to proceed

I tried the above methods but I am unable to get the list of partitions on my mobile, on the computer it is showing that the removable drive is corrupted and it needs to be formatted. I faintly remember that I had installed helium app for backup and it had super user access , i suspect problem created by this app.

Also does a custom ROM update help in this? if yes please specify the best ROM for karbon s5, can I proceed installing kitkat on this bricked device?

  • Welcome to the Android Enthusiasts! Would you mind to edit your question and include an excerpt of "this solution"? If the owner at XDA decides to delete his post, the reference would be lost otherwise. Also it's not nice to let us check out details on other sites just to be able to understand your question, so many will simply skip it probably. Doesn't hurt to list up what you've tried already, either ;)
    – Izzy
    Nov 22, 2013 at 7:22
  • Thanks! I improved formatting a little for better readability. Not knowing/having the device, I now have to pass on to somebody else, who hopefully is able to help you out. Good luck!
    – Izzy
    Nov 22, 2013 at 13:40

1 Answer 1


When I went to service center with this problem , they gave the reason that this is because of a full battery drainage. And they were correct. After recharging the battery it worked. It was unexpected. Also after a few days it again showed this message but after restarting the Phone it worked again. I suspect the problem has to be something related to battery or charging. Its now a month I am not getting this error. I am glad that I was not able to try the above methods.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .