I cannot access local HTML files at external SD card on my Lenovo S6000 within Chrome. It is mounted at /mnt/extSdCard. Browsing to file:///mnt/extSdCard does show this message:

The file at file:///storage/sdcard0/foo/bar.html is not readable. It may have been removed, moved, or file permissions may be preventing access. Error code (ERR_ACCESS_DENIED)

I've tried multiple browsers. Some show the app and doesn't work, some show the app and does work, some show the above error. Interestingly, I have 2 tablets. The one with updated firmware is the one that doesn't work. I held off on the update on the 2nd and Chrome works with local HTML files.

From comments:

$ls -l index.html
-rw-rw-r-- root  sdcard_rw  8097  2013-11-20 10:40 index.html
  • Just to add, file path etc is all correct. Permissions are there. Even added the permission group 'Everyone' with full permissions just to make sure. Nov 27, 2013 at 14:39
  • Welcome to the site! Just to be sure, (if you have a Terminal app or ADB Shell) could you please edit your question and give us the output of ls -l /path/to/foo/bar.html?
    – dotVezz
    Nov 27, 2013 at 14:43
  • I'm not familiar with what your trying to find out. I'd be happy to let you know. Do I need to enter a certain 'command' in a terminal app? Nov 27, 2013 at 14:53
  • Yep. Enter the command ls -l /mnt/extSdCard/foo/bar.html (Make sure you use the actual path and name of the .html file in question). It will output some information, including permissions and owner data.
    – dotVezz
    Nov 27, 2013 at 14:56
  • 1
    I doubt it is a permission problem: SDcard uses FAT, which does not support permissions this way. The culprit is more likely the "space" character in your path, which some app handles correctly while another one fails. Have you tried using a different path which does not contain any spaces or special chars? One more thing to try is replacing the space by %20 in your URL, e.g. file:///mnt/sdcard/space%20path/index.html.
    – Izzy
    Nov 27, 2013 at 16:13

1 Answer 1


In case some one else comes across this. I did not completely figure out why 1 updated firmware tablet works and 1 non updated tablet does not with the same file path from sdcard0. I did notice on the updated firmware tablet in storage I have folders emulated(read only), sdcard0(read/write), and sdcard1(neither). What I understand these are android 4.2 multiuser folders.

Using the html file from either legacy/0 folders within the emulated folder turns out to work fine with Chrome. Both those folders are read and write. So that is my solution for now.

Side note, the emulated folder is not on the non updated firmware tablet.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .