4

I recently updated my Samsung Galaxy S-I9000 to Android 4.4 KitKat, It was successfully updated and KitKat worked fine until I decided to try using the ART RunTime instead of Dalvik.

When I changed runtime to ART and rebooted the phone it never started up. I see the Samsung Galaxy S I9000 logo and then comes the running CyanogenMod circle which never stops. I let it work for more than four hours and it was not fixed.

Note: Once when rebooted for changing runtime phone was powered off. Charged and resumed the process, the same result. I also tried installing cm11 update once again, no change.

If there's a way I can fix this issue, I would be grateful to know how. Thanks in advance.

UPDATE[FIX]: I wiped everything, Including Dalvik cache, partition cache and data, then tried installing the ROM, problem fixed. And screw ART for now, it needs some time to get stable and ready for everyday usage. I'll just stick with dalvik. I couldn't respond faster due to my noob account restrictions.

  • As that is a setting the user can switch, a factory-reset should restore its previous state. Have you tried that? – Izzy Nov 30 '13 at 14:21
  • Yea, I tried that a couple of hours ago and it worked. Thanks for your response. – The Hoss Nov 30 '13 at 20:45
  • Thanks for your feedback! As this obviously is a working solution, I made that an answer. Would be great if you could "accept" it (using the check-mark next to it) to make this obvious for other possibly affected users :) – Izzy Nov 30 '13 at 21:08
  • I just ran into the same problem on my Nexus 4. I'm going to be pretty furious if a factory reset is the only way to fix this. – kevinmicke Jan 5 '14 at 3:52
  • 1
    The question just made me laugh... – Android Quesito Feb 21 '14 at 21:08
3

As "ART" versus "Dalvik" is a setting the user can switch, a factory-reset should restore its previous (default) state – in this case, revert it to "Dalvik". Reportedly, the following steps solved the issue in this case:

  1. Complete wipe, including Dalvik Cache and data (can be done from , and is equivalent to a )
  2. Re-flashing the ROM (IMHO an optional step, as the previous one should suffice)

Remark: There's a good reason that switch is a little hidden; ART is still "experimental", and not intended for "everyday use". It was placed with the developer's options just to give developers a way to already test their apps for compatibility.

0

Success! I had the same exact problem on my Nexus 4, and all it took to get mine working was a forced shutdown, and starting it up again. For the Nexus 4, that's simply:

  1. Hold down the power button for about 10 seconds (the phone will shut down)
  2. Hold down the power button for about 2 seconds (the phone will start up)

Mine ran through the same "Optimizing app X of Y" that it had before, but seemed to do so faster than it had the first time, and then actually finished booting. When I went to check if Android Runtime was still chosen, it wasn't - it had failed back to Dalvik, which is where it's going to stay on my phone for now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.