0

I am attempting to flash a modified Android build to my Nexus 7 tablet.
I am following this tutorial from Google, and using the specific build commands found here for my device, full_grouper-userdebug.

With the device in fastboot mode and connected to the PC, I run the following commands:

$ . build/envsetup.sh (Initialize build environment.)
$ lunch full_grouper-userdebug (Configure the build for specific device.)
$ make -j8 (Build the source.)
$ make fastboot adb (Build fastboot and adb.)
$ fastboot -w flashall (Flash build to device.)

At this point, I receive the following error:

error: cannot open '~/<source path>/out/target/product/grouper/system.img'

When I issue a find command, nothing is returned:
$ find ~/<source path>/ -name system.img
$

Why does the file not exist? Without it, I do not know how to flash my modifications. Any ideas?
I am using Ubuntu 13.10.

closed as off-topic by geffchang, Izzy, Lie Ryan, Ryan Conrad, Zuul Dec 7 '13 at 12:18

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions about writing and publishing Android apps, writing custom ROMs, and other topics that are primarily of concern to developers are off-topic. Consider taking advantage of other resources that may be appropriate for your question." – geffchang, Izzy, Lie Ryan, Ryan Conrad, Zuul
If this question can be reworded to fit the rules in the help center, please edit the question.

1

It looks like the build did not complete successfully. Run make again. It should try to resume from the point the build failed, whereupon it'll encounter the same error again. Probably the error message will tell you what went wrong: possibly it's a problem with the software you need to build the source, or likely the way you've "modified" the build has caused the problem.

If you can't work out yourself what the error message means, then our sister site Stack Overflow will be able to offer specific help if you tell them the message and your situation.

Not the answer you're looking for? Browse other questions tagged or ask your own question.