3

I turned on mobile data and hotspot in my Samsung Galaxy Ace (On a Philippine carrier called "Globe"). I can surf websites just fine directly on Android.

Now, I connect my PC to Android's hotspot, it connects but it can't surf or ping websites.

It used to work before (used it some months ago) but now it doesn't. What could the problem?

Edit:

ipconfig screenshot:

enter image description here

8
  • 1
    This could be a local networking issue. Can you get the network configuration info from your PC? If you're on Windows, could you update your question with the output of ipconfig from a Command Prompt while connected to your hotspot? (Please edit your question with the information)
    – dotVezz
    Dec 2, 2013 at 16:51
  • What carrier is the device on?
    – Compro01
    Dec 2, 2013 at 17:26
  • @dotVezz updated with ipconfig
    – IMB
    Dec 2, 2013 at 17:34
  • @Compro01 This is a Philippine carrier, Globe.
    – IMB
    Dec 2, 2013 at 17:34
  • I had the same, although intermittent, problem recently. Whilst it would be OK for periods of time, my connection would drop and be unable to connect to sites, whilst the phone connection was still OK. In the end I put it down to the fact I was still connected to my wired LAN through which I would normally connect to the internet (my main broadband connection was down for a few days, hence why I was tethering via mobile). If I disconnected completely from my LAN (which wasn't desirable) I would regain the mobile connection.
    – MrWhite
    Dec 2, 2013 at 17:49

4 Answers 4

1

If you are using the built in Wifi Tethering in Settings, then Android might have automatically misconfigured the iproutes.

You can try clearing the data on the tethering app and settings to refresh the configuration. Open Settings -> Applications -> click Settings -> Clear Data.

Same procedure for the tethering app, Open Settings -> Applications -> click ">your tethering app here< -> Clear Data

and to add, I'm also a Globe/Sun subscriber :D

0

Try to ping DNS eg google DNS "ping 8.8.8.8 -t" if it replied, then your problem might be browser specific. Check if you do not have proxy settings set on your browser.

If it does not reply, make sure you do not have a VPN software installed on your Android device, Tethering will not work with VPN installed on Android. Also make sure you do not have active VPN on your PC too as this will change the default route of the network.

0

Try giving DNS configuration manually. It solved this issue for me.

0

Apparently some mobile operators block tethering by checking the browser "User-Agent" when you request a web page...I don't know if this still happens but it was widespread a few years ago. Basically if the User-Agent doesn't say "I'm a phone" the request is blocked. There are ways to change the User-Agent on some PC browsers so it might be worth giving that a try.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .