1

I have a Samsung Galaxy S2 (Sprint, codename d710), and I just installed the latest CM nightly (10.2). Everything worked until I encrypted the device. Now the radio doesn't work (network: UNKNOWN, no service, etc.). I looked at each of the mobile network settings and didn't find anything; I also tried about 10 different modem updates (packaged as .zip, installed through Clockwork Mod).

I verified that it happens immediately after an encrypt from a fresh install of CM nightly 10.1-2013-11-17.

Is there anything to do short of wiping and reinstalling? What's the source of the problem, and how can I prevent it from happening again?

1

Cyanogenmod nightly builds are development snapshots. Anything can be broken in them from one night to the next. You shouldn't try to use a nightly for your "everyday" phone as problems like the one you describe are common.

Report the bug to the developers and switch to a stable release (or, if you're feeling brave) a release candidate or milestone release.

  • unfortunately there aren't any releases past nightly yet. I'll update if I get the same issue on a more stable release, when it comes. I'm willing to bet it still happens. – bright-star Dec 3 '13 at 9:33
  • Of course it'll still happen if you don't tell the developers what is wrong. Bugs don't just fix themselves, you know. – Dan Hulme Dec 3 '13 at 9:35
  • I checked in with both relevant IRC channels; unfortunately, new accounts can't post to the CM forums. – bright-star Dec 3 '13 at 9:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.