I have a Galaxy S2 running Android 4.1.2. It has a 12GB internal HD, and a 16GB SD card.

I keep getting errors from various programs telling me I am running out of space. BeyondPod won't download new episodes, Evernote keeps putting up a notification of a lack of space (even though it seems to be storing everything), and sometimes apps won't update.

I have tried to ensure I have no superfluous apps, and I haven't really changed the apps I use since I first ever started using the device. I keep any large files, like music collections or videos, on my SD card.

When I connect my device by USB to my Linux computer and check the properties of my 12GB HD, it says 9.9 GB is used. But if I browse the files, every folder seems to have barely kilobytes of information.

Why is my 12GB HD filling up, and how do I clear it out so I don't get these errors?

Update: My phone is rooted, so if that is something that can help me in this situaton, then root access is available to me.


Signed up to the site specifically to answer this question. I'm also using a Samsung Galaxy S2 with lots of storage but constantly full. I could not install applications or do pretty much anything.

I'm using Cyanogenmod, but this applies to all Androids.

What I did was using a file explorer with Root Permissions (to see all the files), navigated to the /data/logs folder.

The contents of the folder totalled over 1 GB, causing the problem. I deleted all files in that folder and it workes fine now.

As to why this is happening, I don't know - but I do know how to fix it. Hope this helps!

| improve this answer | |
  • This may be the answer. In my /data/log (no 's' on 'log') folder, there was about half a gigabyte of data. Clearing this out seems to have helped, as I'm now getting less errors, but I'm going to run for a day or so to be sure. – Questioner Dec 14 '13 at 2:41
  • Just an additional note for anyone who might be coming across this later: I was confused about the difference between the internal SD card and the internal HD of the device. The internal HD is about 2GB, and the internal SD is about 12 GB (and then there's the additional external 16GB drive.) I kept thinking that if I clean up my 12GB drive that would help, but it's the internal system drive, that is not visible when you connect by USB, where cleaning files was needed. – Questioner Dec 18 '13 at 4:37
  • I'm on Cyanogenmod as well, and this has happened to me a few times. I don't know anybody running a stock ROM that has had this issue. (Thanks for the solution.) – x4nd3r Sep 22 '15 at 23:43
  • 1
    Any solution for non-root devices? – Lenin Raj Rajasekaran Nov 7 '16 at 0:47

If you're getting "storage space runout" on your Samsung S2 phone, just dial *#9900# on the tablet and select option 2 “Delete dumpstate/logcat”

It's not necessary to root your android. Restart your phone afterwards.

| improve this answer | |
  • Thanks for the answer, I read this in a forum a while back when I activated encryption the last time, but I forgot where – Alex Lehmann Aug 11 '14 at 22:38
  • Awesome. This freed up over 800mb for me and is easier than installing a file explorer and finding the /data/log folder. – Moob Feb 25 '15 at 18:43
  • I am getting "invalid mmi code" when I dial that – Lenin Raj Rajasekaran Nov 7 '16 at 0:46

You need to clear the logging files. Dial *#9900# and select delete dumpstack

| improve this answer | |
  • 5
    Is this any different from deleting the files in /data/log? – Questioner Dec 29 '13 at 7:30

I had the same problem. Couldn't update anything due to insufficient memory. Tried a zillion sites, wasted hours and hours.

The only thing that worked was "You need to clear the logging files. Dial *#9900# and select delete dumpstack" as indicated in an earlier post. Freed up almost a GiB of space.

Go to the dialer, and type EXACTLY star pound 9900 pound (*#9900#). The menu automatically comes up (no need to send or anything). Select the delete dumpstack option (second one down on my phone).

I could just scream at Samsung for having wasted so much of my time, when such an idiot simple solution was available. I got all kinds of idiotic advice about reinstalling firmware, moving photos to SD card, etc. None of that worked.

 *#9900# and select delete dumpstack
| improve this answer | |

Try this app.Do install and check is space getting available or not ? Check Available space and clear unwanted files

| improve this answer | |

Check the file /system/etc/gps/gpsconfig.xml specifically the variable cLogEnabled. If that's setted to true then go and check the size of gps logs files under /data/gps. If those files are big then that's your problem.

You can do that using adbshell and basic linux commands (I don't remember if du was available in stock android).

If this is your problem you'll need to change that variable to false, most certainly you'll need root for that. Or maybe mark this bug to samsung and hope for an update or solution from them.

| improve this answer | |
  • Thank you for replying. I can not find a directory called gps in /system/etc/. – Questioner Dec 13 '13 at 16:10

Some apps don't allow the user to move them to the secondary memory, because maybe they don't know how to do this or because they want to keep their app in the primary memory.

If you are an Android Developer, you can check it out on this App Install Location article. But, if you are just an user, the best idea is to move more applications you can to the secondary memory (SD Card) and store the media files in SDCard as well.

| improve this answer | |

I'm quite sure that your online apps are storing files in your internal memory and not doing a proper garbage disposal, which you need to do manually. You should temporarily remove your SD card and insert your phone in "mass storage mode". Then use a software like File Explorer lite to get a rough idea on what's eating your memory. But I think that most junk file can be found in the "Android" folder specially if you install/uninstall a lot of programs.

| improve this answer | |
  • tip. Right-click the Android folder and select Properties. You might be surprised about its size. – forums Dec 13 '13 at 12:53
  • If I right click on the Android folder and select Properties (Using Ubuntu), it says it's about 210 MB. – Questioner Dec 13 '13 at 16:00
  • ok, so Android folder is clean. Still use any software that has a pie-chart view to check which files/folders are eating up the memory – forums Dec 14 '13 at 9:54

You my friend can try X-plore. It is a file management app which can show you much more details of the file system of your phone. It will allow you to view hidden files as well. Maybe you will be able to find the folder with most weight in it ;)


Another method I recommend is using CCleaner Android App. It finds files and cleans your phone intelligently. It is ad free so that is a plus.

| improve this answer | |
  • When the insufficient memory error is triggered, that usually concerns internal storage, i.e. the /data partition. Regardless what file manager used, you cannot fully access this without root access. – Izzy Dec 13 '13 at 11:41

Not the answer you're looking for? Browse other questions tagged or ask your own question.