0

I see there are various threads for Galaxy S3 having this problem, but my phone is Sony Xperia S.

My phone used to connect to PCs fine, but today when I tried connecting to my laptop it wouldn't recognize it. This happens on Windows and on Ubuntu, with the original USB cable, and with a generic one. The same cables and computers used to work fine with my phone.

Also, the phone does not give any notification that a PC has been connected, i.e. the phone itself doesn't recognize that a PC has been connected. It starts charging, though.

I tried rebooting Android, I also tried enabling USB debugging, but none of it helped.

  • Did you try the same cables with a different device? Though pretty unlikely, both cables could be damaged somehow. Apart from that, it might also be one of the USB contacts on your device; charging simply requires two of the 5 contacts available. – Izzy Dec 3 '13 at 14:21
  • @Izzy I just tried the original cable with the Windows machine, and it worked. At the same time, the generic cable isn't working. So it was the cable, after all. – sashoalm Dec 4 '13 at 7:03
  • Glad to read you issue solved, and that easy! Maybe you put this as an answer and accept it, to show your problem has been solved? – Izzy Dec 4 '13 at 7:18
  • I'll try to see why the stock cable didn't work on my laptop at home (but the laptop is on Ubuntu). – sashoalm Dec 4 '13 at 7:44
0

In the end, it turned out it was working for the original USB cable, while the generic USB cable did not allow data connection, only charging.

For the original cable, the problem disappeared on its own, and I don't know what caused it, or what caused it to disappear.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.