0

My HTC one will only boot into the recovery or the bootloader. I am trying to flash a stock ROM to my phone from the terminal on my mac, but I am getting this error:

Mikes-MacBook-Air:HTCOneRoot Mike$ ./fastboot-mac flash zip ATT-3.17.502.3-Stock-Rooted-DEODEX.zip 
sending 'zip' (1114992 KB)...
OKAY [ 37.597s]
writing 'zip'...
FAILED (remote: not allowed)
finished. total time: 37.618s

Mikes-MacBook-Air:HTCOneRoot Mike$
  • "not allowed" sounds like your bootloader is locked, and the "zip" is not an "official" one (i.e. not signed by the manufacturer). – Izzy Dec 4 '13 at 6:55
  • Do you have the stock recovery on the phone? Often you need it there to flash the stock ROM back on the device as it is signed by the manufacturer. It's also possible that the zip file is corrupt (check the MD5 sum). Can you try flashing the zip through the recovery itself rather than the Mac? – RossC Dec 4 '13 at 9:04
1

I don't know how you came up with that command line, but it appears to be incorrect. The format of the fastboot flash command is:

fastboot flash partition imagefile

I've never heard of a phone with a "zip" partition: they're usually called "boot", "recovery", "system", and "userdata".

My guess is that you need to unzip the zip file you've downloaded, which will give you files named something like "boot.img", "recovery.img" and "system.img". It may also include a script that already has the right fastboot commands to flash the whole system (but you'd need to rename fastboot-mac to fastboot to run it), and/or a readme file explaining the process. Read it carefully and follow the steps exactly. Guessing what arguments to give to fastboot will probably result in bricking your phone.

  • Messing with partitions or PIT files is a damn dangerous thing to do, it's worth re-emphasising that fact. I'm not sure why the OP can't flash the zip through recovery. There should be no need to repartition anything in this case. Into recovery, wipe cache and data , Install zip: pre rooted stock zip name from above, done! I just tried it on Galaxy S4 and HTC One, worked in a few minutes. Also some of the better recoveries have techniques to catch the most common causes of bricking and abort before doing the full install. – RossC Dec 4 '13 at 14:29
  • Nobody suggested repartitioning anything. It's just a question of naming the correct partition in the fastboot command. – Dan Hulme Dec 4 '13 at 14:47
  • Sorry I wasn't clear, it is just worth mentioning, from experience that anything involving a partition is dangerous. He's put someting in the 'partition' argument of the fastboot command and that is dangerous itself. Just wanted to re-emphasise that point. Also, I notice a lot of people on XDA saying 'ahh try a different PIT file, flash the Google Edition OTA zip etc' and those kinds of things will 100% brick the device! More of a tangent to your post, probably more confusing than anything! – RossC Dec 4 '13 at 16:17
1

HTCs have a locked bootloader preventing flashing. Use a windows PC and install HTC one usb drivers get them here

Goto htcdev.com/bootloader to get unlock code that you will be needing and install Windroid toolkit to perform the process which you can get here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.