1

I have a very peculiar problem with connecting my new nexus5 to my wifi router @ home.

Here is the background: I recently bought Nexus 5 and a new wireless modem/router(D-Link2750u)...The first day as soon as I got the router, I did the set up and both wired connection to my pc and wireless connection(WPA2-PSK) to my phone worked fine.

Now the problem is

Since the next day my phone does not enable me to connect to my home network. It always shows my SSID as 'Not In range' even though my phone is right next to the router.

My approach to the problem:

I thought since there are 2 devices involved... it can either be the phone's fault or the routers fault.

So, First I choose my phone, I went to my friends place my phone had no problem what so ever to connect to the wifi @ my friend's(Same ISP, same encryption different router) and I try to connect to 2 other different networks and it worked fine.

Now, the only other culprit possible: My router

My friend was able to connect to this network through his Samsung phone and he dint have any problem doing it so.

Now the question that boggles my mind...

who is the culprit in here? My Phone or the router?

I am not able to figure out what might be the problem, Any kind of help is greatly appreciated...

PS: I also tried doing a factory reset of the phone and also reset the router and then set it up, none of them solved the problem.

  • SSID on my router is "visible" btw... – codeMan Dec 5 '13 at 8:48
  • 1
    I remember having a similar issue with a different combo of devices. Sometimes it helps to shortly switch to airplane mode. Other times not, and a reboot does it. Most times, just sit and wait did the trick (after a far too long time of > 30min). Might be the channels, as Aadi suggests, or some software trouble on the device. Not sure if a factory-reset would cure it (I doubt it, since your device is quite new and fresh), or some update (radio/ROM) might be required. Try contacting service, just in case. – Izzy Dec 5 '13 at 11:14
  • Thanks @Izzy ,I have been doin all of those since last 2 days... no luck :( – codeMan Dec 5 '13 at 11:17
  • 1
    Really all? Including flashing a RUU and a new ROM? I guess you mean "all except these two". As you're still under warranty, I'd suggest contact your service hotline before trying one of the two. They might even provide you with a RUU (radio-firmware) to flash, so you don't have to worry about warranty. – Izzy Dec 5 '13 at 11:20
  • Sorry... I dint mess around with ROM! By "all" I mean... reboot, switch to airplane mode, channels... tried it after fully charging the device, changed the place of the router... I will go ahead and contact service... – codeMan Dec 5 '13 at 11:28
1

There might be an issue with the wifi channels enabled on your phone, I am unable to find this setting on kitkat i have no clue why! Maybe I just dont remember how to get there, go on to your router settings page and see the channel being used. Change it and I think that would fix the issue.

  • why the down vote?? – codeMan Dec 8 '13 at 6:25
  • U know what... I kept meddling with all the channels that the router supported and guess what! one is them is working pretty well... from last 24 hours.. :) Thanks @aadi. – codeMan Dec 8 '13 at 8:43
  • You are welcome, although I'm still trying to figure out why my answer got downvoted. Thanks for accepting the answer – Aadi Droid Dec 9 '13 at 6:07
4

This question thread has been very helpful -- I too developed the same problem, which started after 2 events: being away from my home for 2 months, and also receiving the latest Android 4 updates (over-the-air) -- across 3 Android devices: my HTC one, my Nexus 7, and an Alcatel Fierce. All have Android 4+

After hours inside the router's setup panel, testing, I solved it with your help, Izzy. But it wasn't the channel... It was the GHz setting!

The home router was set for 5ghz. everything always worked fine, until the latest Android updates. Now, none will work; all give the same famous message: Not in Range. This is absolutely erroneous, since all PCs/Macs in the house could use the Wifi network just fine. (I won't even mention the brand of router since it doesn't matter.)

To solve the problem, I tried eliminating most variables, in both the router and the android devices:

  • SSID on/off -- didn't matter; not in range;
  • Channel changing -- no effect; still not in range;
  • restarting router and phones and tablets -- no luck;
  • toggling WIFI optimizations/power saving/dhcp-vs-static -- no luck

What DID work was changing the broadcast channel from 5ghz back to the more crowded 2.4 GHz. Success. And rats, I'd rather be using the 5GHz.

So I conclude that this is an Android 4+ software bug. (Phone hardware, you think? How could all three devices have a problem with 5ghz, when they ALL worked fine before on this same network, before joining other networks fine?) There's something wrong with the software such that once they join a 5GHz wifi network, then connect later to another network (cafe hotspot, other network, etc.), they lose the ability to "see" the network they first connected to.

  • This is definitely a software bug. I started facing this ever since the upgrade to lollipop. – nunespascal Apr 26 '15 at 14:58
2

Summing up from the comments:

There are several things which could be tried:

  • switching to a different WiFi channel (as suggested by Aadi already)
  • shortly switch to Airplane mode and back
  • reboot the device
  • wait it out (I had a similar case where it automatically solved after 30+ minutes, but the Airplane trick didn't help)
  • the device (unlikely in your case with just a fresh device, but might be helpful in other cases)

If none of the above helps, and your device is still under warranty, contact the service – as it's most likely an issue with the radio unit (or the ), or some of the "drivers". They either have you send in the device for repair/exchange, or offer you...

  • a radio image to flash, which should fix any issues in the radio firmware
  • a ROM update to flash

If you're no longer have warranty, or don't care, you might find yourself such a fitting image. Sometimes, simply updating the (flashing a new ROM) may solve that as well. Please see Where can I find stock or custom ROMs for my Android device? for possible sources.

0

sometimes i face this problem and i found out a working solution , you can try it if you have this problem too :

  • goto your modem panel
  • goto wireless setting
  • change SSID to something else
  • turn off your mobile wifi and turn it on again
  • you will see the new accesspoint name in your wifi list
  • test it if you are ok with the new name , our work is finished

if you want old name because of your other devises work with that name

  • goto panel and change the SSID to old one
  • turn wifi off and on

you may see the old wifi name is on the top of the list and it may work ( in my case wifi works again with old name )

good luck

0

I was dealing with this Wifi Problems since a week, I tried all the things as suggested by the OP but it was all in vain. My problem was finally solved by [SOLUTION] Changing my Router channel settings from 'Automatic' to 'Channel 11'.

-1

Just received my brand new nexus5 on friday.. and it does not work with my wifi!

the solution is to set a static ip instead of dhcp. it is working for me now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.