3

I'm stacked with the following problem with my first Android device (Ruggear RG960 Apex, Android 4.1.2, rooted using Kingo Android ROOT) I bought about a week ago. The problem is when I'm trying to install Google Calendar from Play Market, I get the following error:

Error: Incompatible with other application(s) using the same shared user ID

The same is true for Google Play services, which are required for the most of Gapps.

I tried the following:

At the same time Google says this problem is a common one, but still I cant find the solution for about a week so far. Perhaps this is because I have quite rare device, which is not so widely described. So, any guidance to the right direction will be highly appreciated.

In case anyone needs some more details about the device / performed actions - will gladly provide them as requested.

  • 1
    Are any of the GApps pre-installed on your device? If so, the manufacturer might have "messed" with them, and broken the certificate. Or maybe you've installed some manipulated GApps package by accident. Flashing a different ROM (if available) might help then, or deleting the GApps manually and then re-load them. But in case it wasn't you bringing the GApps on the device in the first place, I'd rather first try contacting the service line (for warranty issues; though rooting the device might already have voided that, flashing a custom ROM will certainly do so, outside Europe). – Izzy Dec 7 '13 at 21:07
  • @Izzy I have GMaps and GMail already installed. Since the device is rare - no ROMs available, even custom recovery mods say the device is unknown and do not want to install... However, the device has its own Calendar app installed which is synced with GCal, but it is NOT Gcal. I'm in Belarus, so the service line here is not so quick and willing to help)) Anyway, thanks for the suggestions. – Peter L. Dec 8 '13 at 7:40
0

4 months later support finally shared me the latest ROM that solved all the above issues.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.