3

I have a nexus 5 with Android 4.4. If i look at data usage, it shows that Android OS is using a couple of megabytes per day. I tried disabling sync and backup but it didn't help. What could be causing the background data usage? One thing that I could think of is automatic system update check, but there seems to be no way to turn it off.

What could be the cause of the data usage and can I fix it without rooting?

  • I doubt that the update check is causing this. It's just a few bytes every 24h (if you don't manually trigger it all the time). – Flow Mar 17 '14 at 13:19
1

Found out that the issue is not persisting on nexus 4 and only in nexus 5.(Thats very strange.)

Temporary Solution until Google fixes this. Just root your phone and freeze Android System Update. That will fix the mysterious data consumption issue.

0

You could try going to Settings→Data usage, define a global limit (can be imaginary, e.g. 5 GB), and then scroll to "suspect apps": open their entries, scroll down, and check "limit background data". Then those wouldn't use background data while on mobile data, while working as usual when on WiFi or in foreground. That's what I did with e.g. Google Play (to keep it from always checking for updates in background) about half a year ago. No side-effects seen yet.

For details, please see my answer here. You might also want to check What won't function properly on device if I disable background data usage for google play store?

Other related questions include:

And probably several more.

  • 2
    Thanks for the answer, but the updaten 'limit background data' is not available for 'Android OS'. – MeesterPatat Dec 9 '13 at 20:06
  • "Android OS" is in many cases just a "collector" in the stats. Try for Google Play, to start with, then carefully check with Google Play Services (watch out for side-effects, I didn't test with that) and other apps one by one. With some luck you can identify the culprit that way. – Izzy Dec 9 '13 at 20:08
  • I did try that, but it didn't solve the problem. I think the culprit is the auto system update check. Every time i navigate to 'Settings->About phone->systemupdates' It shows that the last update check was less than 10 minutes ago. Basically, it checks for updates every 5 minute or so. Most likely this is the cause of background data usage. The problem is that there seems to be no way to disable it. – MeesterPatat Dec 9 '13 at 20:51
  • Can you check if there's a process called "fota" or similar? Reminds me of some custom ROMs which ship a fotakill along to silence that. You can find out more about fotakill e.g. at this XDA thread. – Izzy Dec 9 '13 at 21:13
  • I looked under apps->downloaden/currently running(cashed processes & Acive Services)/all but couldn't find anything called fota. – MeesterPatat Dec 9 '13 at 21:57
0

This is due to Google Backup.Switch Google Backup off and your problem will be solved.Follow these steps-

  1. Open Photos App.
  2. From options select Settings.
  3. Select Auto Backup and Switch it off.
-1

Go to settings, scroll down to accounts, click your Google account(s), and turn off all the syncs.

protected by Community Nov 18 '14 at 19:58

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.