1

I successfully downloaded Android 4.4 KitKat (see screen shot):

Downloading proccess

And after downloading do not appear "restart/install" button, appear "Verification failed" error (see screen shot):

after_downloading

(click the images for larger variants)

If I click "Check now" button it begin redownload update Android 4.4 kitkat again.

Does anybody know where the problem is, and how it could be solved?

  • Few people have experienced the same issue over at XDA and Android Central. It generally works after a day or two (couple of them reported at xda). If you really want the update, sideload the update. It is easier to sideload the update (no need to unlock bootloader). – k1chy Dec 11 '13 at 4:54
1

Is your Nexus 4 100% stock? (i.e. no Xposed module changes, or low-level tweaks like status bar mods and DPI changes).

Verification will fail if the system files on your device don't match factory/the expected ones. I had this happen to me several times with both my N4 and N5. Reverting the changes I made (thankfully, they weren't too many) fixed it.

  • Thanks @Infinitesimus you are right, but in my situation the other problem was, when goes verification was slow internet speed then appear fail message. Then I connected my device to stable high speed internet and problem disappeared. – mr.boyfox Mar 9 '14 at 7:53
1

You can use the Nexus Factory Images to upgrade your phone to Android 4.4 (now 4.4.2). To do this have a look at this question.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.