11

When I put more than one person as the recipient to my message my Samsung Galaxy S3 vibrates and says it's converting to MMS. When I send my message I know at least one person is not getting the message. However that person can send me a group message and I can see it is as a SMS instead of MMS.

I can't find any options to prevent it from becoming a MMS. I set the delivery report checkbox and sent another one out. I know one person got it and that person did it. I get no report on who got it. I'm using Android 4.3.

  • And what app you use for SMS? You describe the default behaviour of Hangouts (in which case you might want to switch to a different app for SMS). – Izzy Dec 11 '13 at 7:11
  • @Izzy: I'm using the default app for text messaging It's the same as every android I seen but I haven't seen many. What do you recommend? – user24835 Dec 11 '13 at 20:46
  • I'm not a big SMSer; if I write more than a single SMS per week, that's already extensive. For that, the stock app is more than sufficient. So I'm not really the one to recommend an app from my own experience. You might wish to take a look at this list (never mind the German, you'll be able to interprete the list itself), plenty of apps together with (and ordered by) their resp. ratings. Should make a selection easier at least. – Izzy Dec 11 '13 at 22:35
  • 1
    It isn't actually the 'default' one that you have, it is Samsung's default SMS application. It is specific to Samsung devices, they have put layers of their own code on top of the old stock SMS application. The new default is Hangouts for Nexus / AOSP. There are many other apps that do this. If you have a rooted device you can install a Wanam Xposed module that stops the auto MMS conversion in the default Samsung SMS application. – RossC Dec 12 '13 at 10:48
  • @RossC: I see I had no idea. I got one of the free apps. I don't particularly like it but it does send the messages so the few times I need to send a group message I'll use it. – user24835 Dec 12 '13 at 18:07
8

I was facing the same problem for long time on my Galaxy S3, at last i figure it out

by default android SMS allow you to send same message to multiple people without converting it to MMS. But when you Select the option Group Messaging under the multimedia message (MMS) setting it now set group messaging only for MMS

try un-checking the option

hope this will help ( am using default sms of android)

Screenshot
Screenshot (click to enlarge)

  • A note for people it seems that Android 4.3 installs with Group Messaging as MMS option enabled HOWEVER, the box remains un-ticked. In order to go back to the pre-4.3 single SMS sent multiple times you have to tick the Group messaging option, back out, then go back into settings and then un-tick group messaging under MMS.... Thanks Google that cost me a few £ before I noticed. – user49108 Dec 23 '13 at 18:26
  • 2
    On my Nexus 5, the setting is under Hangouts > Settings > SMS > Group messaging which is also enabled by default. – nwellnhof Jun 2 '14 at 17:04
2

When I just saw my T-Mobile bill for Feb it became evident that since upgrading the OS from version 4.1.2 to 4.3 when I send a ‘Group’ text message it creates individual MMS messages, one for each recipient. These are picked up by T-Mobile and charged for at 25p each even though they are text only and I have an unlimited texts allowance.

In addition, if somebody sent me a text message as one recipient of a group text message I do not know it is a part of a group text message but if I reply to the sender then a text message from me is created for each of the recipients. Each of these is an MMS message and so I get charged 25p for each reply message even though I don’t know it has happened.

I rang Samsung and said I am fed up with problems with OS version 4.3 and asked for version 4.2.1 to be re-installed. They referred me to one of their Samsung Repair Centres, The PocketPhone Shop in Cheshunt, to re-install version 4.1.2. However, when I rang them they said they are not able to this but if I bring my phone in they will investigate my problem.

Chris at the PocketPhone Shop did some investigation and then told me that if I go into Text Messages, Settings and then scroll down to Multimedia Message (MMS) Settings there is a parameter ‘Group Messaging’. If this is ticked, when sending Group text messages individual MMS messages are created. However, if this is unticked, group text messaging still works but the messages created are SMS messages and not chargeable MMS messages.

Well done to Chris and I hope this adds additional assistance to the previous helpful messages in this forum.

-1

I found that too. Group text wasn't checked to start with so I checked it then unchecked and now it's back to normal. Thanks for your help

  • Thats exactly what I did and my cousin did to solve it. Good to hear we're not the only ones – user24835 Jan 3 '14 at 16:52

protected by Community Mar 3 '14 at 13:40

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?