1

The app in question is Viral Floating Youtube Popup (a really awesome app, try it). The notification bar says "Couldn't install on USB storage or SD card". Here's my relevant ADB log output as it finishes downloading and attempts to re-install:

  • D/Finsky ( 5512): [1] DownloadQueueImpl.onComplete: com.Mata.YTplayer: onComplete
  • D/Finsky ( 5512): [1] DownloadQueueImpl.remove: Download com.Mata.YTplayer removed from DownloadQueue
  • I/installd( 164): free_cache(0) avail 1346953216
  • D/dalvikvm( 249): GC_EXPLICIT freed 861K, 57% free 6745K/15559K, paused 3ms+9ms
  • W/ActivityManager( 249): No content provider found for permission revoke: file:///data/data/com.android.providers.downloads/cache/downloadfile-3.apk
  • D/VoldCmdListener( 153): asec list
  • I/PackageHelper(10147): Size of container 8 MB
  • D/VoldCmdListener( 153): asec create smdl2tmp1 8 fat {} 10041
  • E/logwrapper(17534): executing /system/bin/newfs_msdos failed: No such file or directory
  • I/logwrapper( 153): /system/bin/newfs_msdos terminated by exit(255)
  • E/Vold ( 153): Format failed (unknown exit code 255)
  • E/Vold ( 153): ASEC FAT format failed (I/O error)
  • E/PackageHelper(10147): Failed to create secure container smdl2tmp1
  • E/DefContainer(10147): Failed to create container smdl2tmp1
  • W/ActivityManager( 249): No content provider found for permission revoke: file:///data/data/com.android.providers.downloads/cache/downloadfile-3.apk
  • D/dalvikvm( 249): GC_EXPLICIT freed 125K, 57% free 6739K/15559K, paused 3ms+8ms
  • D/Finsky ( 5512): [265] 1.packageInstalled: Package install status for "null" is -18
  • D/Finsky ( 5512): [1] InstallerTask.cancelCleanup: Cancel running installation of com.Mata.YTplayer
0

Error "-18" (see the previous-to-last line of your log) is a typical error. Trouble is, there were remains from a previous install left on the SDCard, and now the package manager cannot create a file with a name already existing. There are two possible approaches:

  • if the app is already installed, and you're trying to update: Move it back to "internal storage" (e.g. via Settings→Apps, scroll to the app, open it's entry, and use the corresponding button). Then try to update again. Once succeeded, optionall move the app back to SDCard
  • otherwise: attach the card to your PC using a card reader (or, if you have root access, use a file-manager with root support, e.g. ES File Explorer; without root, Android will hide the folder you need to access). In the root of the card, you should find a folder named .android_secure (note the leading dot!). Navigate into it. Watch out for a file named smdl2tmp1.asec (see the corresponding error message: Failed to create container smdl2tmp1), and remove it. If you had used a cardreader attached to your PC: unmount the card safely, and put it back to your device. Try installing the app again, it should work now.

Reading the log again, it looks like the cause was a little different here: executing /system/bin/newfs_msdos failed: No such file or directory is where the trouble starts. The system was unable to create a "handler" to deal with the FAT file system on the SDCard, thus could not access it (ASEC FAT format failed (I/O error)), and then couldn't deal with the "smdl2tmp1" container because of that. In short: It looks like there's a binary missing (or it's there but lacks the appropriate permissions).

  • Thanks for the input, Izzy. I had done a complete removal of CM9 / HP WebOS factory reset, so there should have been nothing left to get in the way. After re-installing CM9 twice, I searched for that 'smdl2tmp1' file both times with ES File Explorer but I couldn't see it anywhere. I gave up after a bit and installed the next CyanogenMod - CM10 - and it seems to be working fine. Thanks, though ^_^ – Boloar Dec 12 '13 at 7:08
  • That file is inside a hidden directory of your SDCard, which is even hidden from the user when mounted on the device, so I'm not sure whether a "search" on the device itself would show it. As written, the location is <sdcard_root>/.android_secure – that's where your apps go to when moved to SDCard. Just to remember for any eventual "next time". Glad it solved for you nonetheless; of course, formatting the SDCard would have solved the issue as well #D – Izzy Dec 12 '13 at 7:15
  • Lol yeah, I'd had root access and everything. I even searched for it from the Android Debug adb tool via Windows. The .android_secure folder was visible, but it was empty. The WebOS factory reset should have solved it, but it didn't. Oh well, just hoping there isn't a next time hahah – Boloar Dec 13 '13 at 6:34
  • Ugh... Just checked your log again, must have been blind: executing /system/bin/newfs_msdos failed: No such file or directory is where the error starts. The system hence was unable to deal with FAT, and could not access the SDCard because of that! So formatting the card hadn't helped at all, your system was missing a binary. – Izzy Dec 13 '13 at 6:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.