2

Before KitKat 4.4.2 there were a variety of Applications Permissions Manager. They worked but with the release if KitKat 4.4.2 they no longer work. This was a non root application so it ran on non rooted phones.

The ability to disable permissions on Applications is very useful as some need way to many permissions. Unfortunately the Google has no filter on searching for applications based on what they access. So Application Permissions Manager was an excellent security tool.

4

The permissions manager feature of Android is not complete yet and strictly speaking it should not be accessible. In 4.4.2 Google have removed the method that apps such as App Ops and App Ops 4.3 / 4.4 KitKat used.

As far as I know there is currently no way to access this any more. You will have to wait for Google to finish implementing it and provide a built-in method to access, or wait for someone to find another way to access it.

Quote from Color Tiger the developer of one of the apps on AndroidPolice:

Still not working, but here's a quick update:

See line 309 - those are the allowed fragments that can be shown. AppOps was in that commit 3 days ago (line 329), but in the 4.2.2 build that's being sent out that line is removed (we've decompiled the Settings.apk).

We're looking for a possible different entry point (another Activity to accept commands to load the AppOpsSummary fragment), but it doesn't look good.

UPDATE: Apparently Google uses App Ops as an internal testing and debugging tool – it was never designed to be seen by end users, which is why it wasn't given a spot in the system settings, or even the developer options. Source

| improve this answer | |
  • Thank you for that, I have solved my problem indirectly by installing a firewall so no matter what the application wants to do it can now no longer send that data back to base. – Meer Borg Dec 15 '13 at 3:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.