1

I'm having a problem with my nexus 5 and I'm getting mad: I installed Dice player as usual, after a factory reset, but Dolphin browser doesn't ask me which app should it use to play videos (from mobile youtube or other sites).

How can I reset the default app? I tried to look into settings-app-reset to default but nothing. It won't ask me to use another app, it just opens stock browser player. I tried other browsers too but no luck. Tried resetting app preferences but nothing.

I updated to 4.4.2 thinking the issue was solved but again, same problem. I did a full wipe, tried stock ROM and then Purity ROM, different kernels but no luck.

Am I the only one having this issue? Could you try to reproduce it for me?

Steps:

  1. install a browser (dolphin browser or chrome in my case)
  2. install dice player (or MX Player if it gets updated)
  3. open youtube (or any site with video files) from browser and open a video. see if it asks to play it with dice player or it just opens stock browser player
  • What exactly do you mean by "stock browser player"? Do you mean the video opens in Dolphin? – Dan Hulme Dec 11 '13 at 13:26
  • Yes, it opens in Dolphin without asking me if I want to play the video in another player (dice player or MX player).. – user3091184 Dec 11 '13 at 13:32
1

This could just be a shortcoming in Dolphin. It's up to the app to decide if it wants to open a new URL itself, or offer it to other apps. Last year, Firefox had a similar problem, that it wouldn't ever offer a chooser when you clicked on a link in Firefox. Even a link to a YouTube video would open the mobile interface in Firefox instead of offering to open the YouTube app.

From your description, it sounds like Dolphin has the same problem. (I don't have Dolphin to test this myself.) You should report it to the developers and ask them to offer video links to other apps. At least they should be able to confirm whether this is what's happening.

0

I have a Nexus 5 with Kikat 4.4.2

Try this:

  1. Setting>Apps
  2. Select the 'blank app'
  3. Scroll down until you see a button 'Clear defaults'
  4. Click 'Clear defaults'

That how I switch between Chrome and Chrome Beta browser. Hope this help

  • That would help if the user had selected a default app. But the described issue is rather a bug, where this doesn't help (should be fixed meanwhile with 4.2.2). Still, your answer could be helpful for those where it's not the bug, but an accidental "always use" hit :) – Izzy Dec 16 '13 at 7:10
-1

Touch&hold on the video until a menu opens and at the bottom you will see something like open with an app - And thats your prompt ... select your player and have fun ... :DD

-1

Go to task manager and select the defaults tab then select clear defaults. Find the app you need to change then clear the defaults for that app. Next time it should ask you.

  • That's a good guess, but it's the same suggestion as one of the other answers. Izzy already explained why that won't help in this case. – Dan Hulme Aug 27 '14 at 23:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.