I have a nexus 4 and I have been using the music downloader called music maniac. Just recently updated to kitkat 4.4.2 and now when I download music the play music app won't find it in my phone. I can find the file when I look it up in the storage settings, but when I plug it into my computer I look in the same place and it's not there. Anyway I don't know how to make it read the file I guess.

7 Answers 7


Try an Android media scanning process using apps such as SD Scanner (other older media scan apps seem to crash in 4.4). Once done, the new files should show up in Play Music (I personally found Android's background running of the scanning process to be too slow).

It could be due to the .nomedia file (see "Hiding your files from the Media Scanner" on the Android API guide) in the folder containing the files (or even in a parent folder) which prevents the any media from appearing in Play Music. Since .nomedia is a dot file, it is considered a hidden file and your file explorer may not show it in by default and you may have to dig into the settings. OI File Manager has an option to view hidden files.

With regards to not being able to see the files on the computer. Strangely on OSX

  • using the Android File Transfer app that is provided by Google, the MusicManic folder /sdcard/MusicManic appears as a file and not a folder
  • using adb shell, it appears as a folder MusicManic as file in Android File Transfer but folder in adb
  • using AirDroid on my Nexus 4, my computer can connect to the phone and /sdcard/MusicManic appears as a folder which can be downloaded. Android shows it as a folder

So I guess for now, try use AirDroid to transfer the files across.


If you have an app like astro file manager you can just copy/paste the file from the music maniac folder to the Music folder. It'll then be in your music player playlist. If you go to the downloaded songs tab in the music maniac app and hit the menu button, it'll tell you the file path. I think it's storage/emulated/0/music maniac. This is on my HTC One.


I've had similar issues in connection with ROM upgrades but never figured out the cause, it never seemed to be permissions related for example, but a solution that I seem to remember worked was to "re-write" the files. Essentially you cut the files over to your PC and then copy them back in, making them "new" files from the Android device's perspective, and they show up. Might work for you, it's worth a shot.

  • That sounds like a failing media scanner: does a device reboot have the same effect? Or unmounting/mounting the SDCard? Both would trigger the Media Scanner.
    – Izzy
    Dec 12, 2013 at 10:30
  • From what I remember, rebooting the device had no effect.
    – pzkpfw
    Feb 12, 2014 at 16:13
  • 1
    Your case might be a little different from the OPs; "resetting" the media library (deleting cache/data) might have solved it, if it only figured files with a "newer timestamp" needed checking (deleting its cache+data would have forced a "full rescan"). But looks like that's completely hypothetical now ;)
    – Izzy
    Feb 12, 2014 at 16:21

What is the music format of the files? It seems that the Google Play Music app cannot recognized some file formats, just like .WMA files. I have got such music files like this on my Android devices and Google Play Music does not find them too. I solved this problem by using another music player. I use VLC for Android and it recognizes all my music files. Moreover you can specify to it the folders containing your Music (in case some of the music files which should belong to your media library are not in the Music folder). VLC is still in beta version and misses some features but it will be the best Android media player when he comes out of Beta.


I had a load of mp3 files which I tried to copy onto my HTC One and after spending weeks trying to get the media scanning working I eventually tried an Android Conversion App (MediaConverter) from Google Play. I re-converted them to mp3 and after that they showed up.



I've had this problem and the fix for me was something as silly as just renaming the folder. I originally created the folder, then moved music into it. This probably caused the issue, but I'm not sure.


Play Music (for me anyways) seems to only see files in the Music/ directory. If your songs are in another folder, move them into the Music folder and see if that works. If you don't have this folder you may need to create it. Play Music also seems to have a problem with files that have not been transferred from your computer over USB. Try moving your files out of the Music folder and back in again.

You must log in to answer this question.