I am not able to flash my Nexus 4 with Cyanogenmod 11 anymore. The installation does not successfully finish, which is probably why it gets stuck in a boot loop after restarting the phone.

During the initial installation by sideloading the Cyanogenmod 11 zip, the process stops at the step Installing update..

It never says update finished. So I just restarted the phone manually afterwards. But it does not boot Cyanogenmod successfully.

The phone either...

  • ...gets stuck at the Cyanogenmod boot splash indefinetely
  • ...gets stuck at the window Android is upgrading.. / Starting apps.

I have formatted the following partitions beforehand to perform a clean install: /system, /cache, /data, /persist, /firmware

  • 1
    When it gets stuck at boot splash, does the cyanogenmod logo appears, so is just blank?
    – Anoop K P
    Dec 13, 2013 at 8:29
  • 1
    @AnoopKP The cyanogenmod logo appears 100% working. The blue arrow keeps spinning indefinitely. Dec 13, 2013 at 9:08
  • How did you did you flash CM? Did you use CWM? If yes, what version?
    – geffchang
    Dec 13, 2013 at 9:28
  • Did you verify the MD5 sum of the ROM first? It could be a corrupted / incomplete zip file. What recovery are you using? I would do a full wipe of all partitions again, redownload the firmware and try it again. Also I would get another ROM to try (even if you don't intend to use it). Can you restore a nandroid even? Also, ensure you are flashing the correct ROM for your version and that you are flashing the correct gapps! (I've been here a few times before!)
    – RossC
    Dec 13, 2013 at 13:02
  • @geffchang I flashed CM by manually by entering recovery mode, wiping partitions and sideloading the installer zip. Dec 13, 2013 at 15:12

1 Answer 1


I had suspected that formatting additional partitions like /firmware and /persist might be somehow related my boot loop - but I have no educated confirmation of this! Any CM aftermarket firmware that I tried would get stuck at the boot though.

The following solved my problem:

  1. Install the (latest) Google Stock Android - this is just as easy as installing Cyanogenmod
  2. Install ClockworkMod Recovery
  3. Install Cyanogenmod Rom

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .